[APP] TelecommandeFreebox


#21

Yes after adding your app I see my consol training. I will try on my snips server.


#22

When i try in the consol i got this :

May be more training is needed, i don’t know


#23

Don’t change for me :frowning:

Is it normal that your app doesn’t have multiple intents ?


#24

I don’t know what to say, I don’t know where the problem may come from. May be a consol problem


#25

Same problem when install on my HW. No default volume / channel to configure and TurnOnJeedom when I said “allume la freebox”.


#26

How did you update your assistant on your server ?

Did you did it with this link image


#27

I did it with SAM INSTALL


#28

something like this :

sam install assistant -i proj_XXXXX


#29

By using this command, I have this message during installation :

Veuillez me dire qui vous êtes.
Lancez : git config --global user.email "Vous@exemple.com"
git config --global user.name “Votre Nom”
pour régler l’identité par défaut de votre compte.
Éliminez --global pour ne faire les réglages que dans ce dépôt.
fatal: unable to auto-detect email address (got ‘hydro@snips.(none)’)

And it continues after without problems.

Edit : I add git info but same problem with the app so the error doesn’t come from here.


#30

Ok, can you connect in ssh to your snips serveur ? Are you comfortable with the command line ? if you are when you are connecter to your server do this :slight_smile:

sudo rm -rf /var/lib/snips/skills/snips-app-TelecommandeFreebox

then you exit and use sam again to install your assistant

sam install assistant -i proj_XXXXX

With this you should have the last version of the freebox app (with the default channel et default volume level), but i can guarantee that “allume la télé work”, but normaly “démarre la freebox” should (i cross my finger)

I don’t know why the update doesn’t work, i have to see that with other dev


#31

Ok ok so the update work, it asks me for default volume / channel (nice add by the way !)

But “démarre la freebox” still doesn’t work.

Do I need to remove all training with “démarre” from jeedom or only "télévision / tv / télé " ?


#32

Good we made some progression (and thanks)

I didn’t remove “démarre” from jeedom’s intent, only télévision, but removing télévision doesn’t work for me, that why i add sentences with freebox in

But i don’t know why now snips recognize what i say, may be because i train a lot for my test :man_shrugging: i’m not really sure and i don’t have answer yet from snips dev :face_with_raised_eyebrow:


#33

Is it normal that your app has only one intent ?


#34

Yes this is normal, this intent add all the sentence to ask to snips and slot word and synonyme to find in sentences. After that it’s my python programme that do the job… if snips tell him


#35

Hello,
Tested on my side as well : in the snips console, “démarre la freebox” always calls TurnOnJeedom.
And by the way, “relance la lecture” calls “WindowDevicePauseJeedom”.


#36

:hot_face::hot_face::exploding_head::exploding_head: :sweat_smile:

@Bonson for “relance la lecture” it seems normal to me, this sentences wasn’t in my intent and in my slots, i added them now

@Bonson and @Hydro i made some modification in the slots to launch the freebox, in the synonym now i put “allume la freebox”, “coupe la freebox”, “arrête la freebox”, “démarre la freebox”, i add this pattern to the sentences of the intent hope it can overpass the jeedom app.

Can you install your assistant again and tell me if it work a little bit more ?


#37

Hi @Bonson and @Hydro , have you better result with the app on the power command ?

I see lot of people that fork the app, it’s not necessary, juste intall it. If i made changes in slots and intent you’re not going to have them, so becareful :slight_smile:


#38

No improvements for me even with stock app.


#39

I’m really sorry, the only solution i can see for now, is that you add some word in slot

Add something that’s not corresponding in jeedom app, may be like “ouvre un pot de mayonnaise” (:laughing:)

Then add the same sentences en select all word as TvCommand

After that install the app again and test with this sentence the freebox can power on and off

If this work then it really a problem with snips and you have to add special sentences that not interfere with jeedom’s one, if you have some sentence to that i can add i update the app with for the power option


#40

Sorry I didn’t understand well what to do.

I must add a random sentence into jeedom app (ouvre un pot de mayonnaise for example) and add it into freebox app too but with all words as TvComand right ?