[APP] TelecommandeFreebox


#41

No sorry i was meening in my app add in the slot TvCommand (in the power line) a synonym with your own sentences like my example, then you add this sentences in the intent of my app, you let train your assitant, then you install it


#42

Ok now when I write ‘allume la freebox’ on my console, I have ChannelFreebox :slight_smile:


#43

Good news :stuck_out_tongue: Hope if you install app again it be effective this time


#44

I tried it tonight but now whatzver commands from freebox’ I said, session was ended because one of the component didn’t response in timely manner.

Anyway to debug that ?


#45

I didn’t got this bug for now. I’m going to try tomorrow to made a clean install of my app to see if i got this problem too


#46

I don’t know if it’s relevant to your app, I have this error for others too.

But mute tv was working before not anymore :frowning:


#47

Really strange, may be try to delete my app from you assistant, install your assistant again and see if without my app you have this problem


#48

I tried from the beginning with only jeedom app and I have the same problem with one action, so no relevant to your app :wink:


#49

Good news for me, but not for you :frowning:


#50

Ok so I start from the beginning and I change hyper-v to workstation to hosting snips server.

My jeedom commands work but not the freebox ones. Is there a way to debug ?

I look skill-server logs but I found nothing :frowning:


#51

So first :

  1. The freebox app is in your assistant and your assitant is install with it on you snips server ?
  2. Did you enter the freebox remote number ?
  3. For debug you can make a sam watch and the ask snips “demarre la freebox” and see if the freeboxapp is detected

#52
  1. Yes
  2. Yes
  3. I launched it with Sam watch, and it detected the right intent but nothing after


#53

Did over command works ? like change channel or volume up and down ?

In a web browser can you try this URL (replace FreeRemoteCode by your remote code), if you validate this url you can power down or up your freebox revolution.

http://hd1.freebox.fr/pub/remote_control?code=FreeRemoteCode&key=power

If it works you can do on your snips server

sudo systemctl stop snips-skill-server

then

sudo snips-skill-server -vvv

and then ask for power your freebox to see if something goes wrong


#54

Url works, so when I try your command I have ;

INFO :snips_skill_server_lib::runner: was asked to stop, terminating childs before quitting...
[23:19:33.179608] DEBUG:snips_skill_server_lib::handler::nosandbox: sending kill to app_freebox_telecommande
[23:19:33.179617] DEBUG:snips_skill_server_lib::handler::nosandbox: waiting for app_freebox_telecommande to stop
[23:19:33.179755] DEBUG:snips_skill_server_lib::handler::nosandbox: app_freebox_telecommande has stopped

#55

It look like you have a snips problem with the snips-skill-server, it look like it shutdown . So it can’t launch the app.

Normally you shoud see something like that :

[08:08:04.994419] DEBUG:snips_common_cli::cli: conf lookup: snips-skill-server.skill_dir -> Ok(None)
[08:08:04.994703] DEBUG:snips_common_cli::cli: conf lookup: snips-common.skill_dir -> Ok(None)
[08:08:04.994759] DEBUG:snips_common_cli::cli: conf lookup: snips-skill-server.skills_root_dir -> Ok(None)
[08:08:04.994824] DEBUG:snips_common_cli::cli: conf lookup: snips-common.skills_root_dir -> Ok(None)
[08:08:04.995271] INFO :snips_skill_server_lib::runner: searching dir for actions: /var/lib/snips/skills/snips-app-TelecommandeFreebox
[08:08:04.995928] INFO :snips_skill_server_lib::runner: found action "/var/lib/snips/skills/snips-app-TelecommandeFreebox/action-app_freebox_telecommande.py"
[08:08:04.998465] DEBUG:snips_skill_server_lib::runner: [app_freebox_telecommande][err] thread started
[08:08:04.998827] DEBUG:snips_skill_server_lib::runner: [app_freebox_telecommande][out] thread started
[08:08:25.143297] INFO :snips_skill_server_lib::runner: [app_freebox_telecommande][out] [Recept] intent Tarlak:ChannelFreebox
[08:08:25.143477] INFO :snips_skill_server_lib::runner: [app_freebox_telecommande][out] Lancement de l'application Telecommandereebox
[08:08:25.143677] INFO :snips_skill_server_lib::runner: [app_freebox_telecommande][out] [Recep] intent value: power