ASR Not responding

Hello,

Please I just upgraded my Snips on a RPi3 +, and for some reasons my ASR no longer seems to be responding. Bellow is my snips-watch output

[00:23:42] Watching on localhost:1883 (MQTT)
[00:23:44] [Hotword] detected on site living_room, for model default
[00:23:44] [Asr] was asked to stop listening on site living_room
[00:23:44] [Hotword] was asked to toggle itself 'off' on site living_room
[00:23:44] [Dialogue] session with id '1beec048-7117-406c-844c-90d46884e3ea' was started on site living_room
[00:23:44] [AudioServer] was asked to play a wav of 41.1 kB with id '676c89d2-14d5-4e60-916d-61ac8a489a69' on site living_room
[00:23:59] [Dialogue] session with id '1beec048-7117-406c-844c-90d46884e3ea' was ended on site living_room. The session was ended because one of the component didn't respond in a timely manner
[00:23:59] [Asr] was asked to stop listening on site living_room
[00:23:59] [Hotword] was asked to toggle itself 'on' on site living_room

Can someone help me?

If I send data to be parsed directly to the NLU, it works fine. But can be seen, the ASR is told to stop listening, just when the wakeword is detected.

I have uninstalled and reinstalled again and still nothing.

Kind regards

dpkg -l | grep snips
ii  libatlas3-base                  3.10.3-1-snips                    armhf        Automatically Tuned Linear Algebra Software, generic shared
rc  snips-analytics                 0.63.2                            armhf        Snips Analytics
ii  snips-asr                       0.63.2                            armhf        Snips Automatic Speech Recognition
rc  snips-asr-google                0.57.8                            armhf        Snips Automatic Speech Recognition using Google API
ii  snips-audio-server              0.63.2                            armhf        Snips Audio Server command line interface
ii  snips-dialogue                  0.63.2                            armhf        Snips Dialogue Manager command line interface
ii  snips-hotword                   0.63.2                            armhf        Snips Hotword command line interface
ii  snips-injection                 0.63.2                            armhf        A CLI tool to manage words injection into Snips ASR models
ii  snips-kaldi-atlas               0.24.2                            armhf        Snips/Kaldi C/C++ wrapper
ii  snips-nlu                       0.63.2                            armhf        Snips Natural Language Understanding command line interface
ii  snips-platform-common           0.63.2                            armhf        Base package for configuration
ii  snips-platform-voice            0.63.2                            armhf        Metapackage for snips-platform voice assistant
ii  snips-tts                       0.63.2                            armhf        Snips TTS
ii  snips-watch                     0.63.2                            armhf        CLI tool to monitor what the snips platform is doing

Hello!

sudo systemctl status snips-*? Everything running?

Hello Boss,

thanks for your response and below is the output

pi@HomeServer:~ $ sudo systemctl status snips-*
● snips-injection.service - Snips Injection
   Loaded: loaded (/lib/systemd/system/snips-injection.service; enabled; vendor
   Active: active (running) since Sat 2019-06-08 16:26:42 BST; 17h ago
 Main PID: 559 (snips-injection)
   Memory: 2.8M
      CPU: 5.077s
   CGroup: /system.slice/snips-injection.service
           └─559 /usr/bin/snips-injection

Warning: Journal has been rotated since unit was started. Log output is incomple

● snips-nlu.service - Snips NLU
   Loaded: loaded (/lib/systemd/system/snips-nlu.service; enabled; vendor preset
   Active: active (running) since Sat 2019-06-08 16:26:50 BST; 17h ago
 Main PID: 813 (snips-nlu)
   Memory: 137.3M
      CPU: 14.850s
   CGroup: /system.slice/snips-nlu.service
           └─813 /usr/bin/snips-nlu

Warning: Journal has been rotated since unit was started. Log output is incomple

● snips-asr.service - Snips ASR
   Loaded: loaded (/lib/systemd/system/snips-asr.service; enabled; vendor preset
   Active: active (running) since Sat 2019-06-08 16:26:42 BST; 17h ago
 Main PID: 543 (snips-asr)
   Memory: 41.1M
      CPU: 9.124s
   CGroup: /system.slice/snips-asr.service
           └─543 /usr/bin/snips-asr

Warning: Journal has been rotated since unit was started. Log output is incomple

● snips-dialogue.service - Snips Dialogue
   Loaded: loaded (/lib/systemd/system/snips-dialogue.service; enabled; vendor p
   Active: active (running) since Sat 2019-06-08 16:26:49 BST; 17h ago
 Main PID: 803 (snips-dialogue)
   Memory: 3.3M
      CPU: 12.462s
   CGroup: /system.slice/snips-dialogue.service
           └─803 /usr/bin/snips-dialogue

Jun 09 10:09:16 HomeServer snips-dialogue[803]: INFO:snips_dialogue_lib::coordin
Jun 09 10:09:16 HomeServer snips-dialogue[803]: INFO:snips_dialogue_lib::coordin
Jun 09 10:09:31 HomeServer snips-dialogue[803]: INFO:snips_dialogue_lib::coordin
Jun 09 10:09:31 HomeServer snips-dialogue[803]: INFO:snips_dialogue_lib::coordin
Warning: Journal has been rotated since unit was started. Log output is incomple

● snips-tts.service - Snips TTS
   Loaded: loaded (/lib/systemd/system/snips-tts.service; enabled; vendor preset
   Active: active (running) since Sat 2019-06-08 16:26:49 BST; 17h ago
 Main PID: 804 (snips-tts)
   Memory: 3.3M
      CPU: 6.387s
   CGroup: /system.slice/snips-tts.service
           └─804 /usr/bin/snips-tts

Jun 09 10:01:26 HomeServer snips-tts[804]: WARN:snips_tts_hermes::pico: No langu
Jun 09 10:16:15 HomeServer snips-tts[804]: WARN:snips_tts_hermes::pico: No langu
Warning: Journal has been rotated since unit was started. Log output is incomple

● snips-audio-server.service - Snips Audio Server
   Loaded: loaded (/lib/systemd/system/snips-audio-server.service; enabled; vend
   Active: active (running) since Sat 2019-06-08 16:26:49 BST; 17h ago
 Main PID: 800 (snips-audio-ser)
   Memory: 4.3M
      CPU: 47min 38.899s
   CGroup: /system.slice/snips-audio-server.service
           └─800 /usr/bin/snips-audio-server

Jun 09 10:09:16 HomeServer snips-audio-server[800]: Expression 'PaAlsaStream_Con
Jun 09 10:09:16 HomeServer snips-audio-server[800]: thread 'portaudio.player' pa
Jun 09 10:09:16 HomeServer snips-audio-server[800]:  -> caused by: InvalidSample
lines 51-73
   Active: active (running) since Sat 2019-06-08 16:26:49 BST; 17h ago
 Main PID: 804 (snips-tts)
   Memory: 3.3M
      CPU: 6.387s
   CGroup: /system.slice/snips-tts.service
           └─804 /usr/bin/snips-tts

Jun 09 10:01:26 HomeServer snips-tts[804]: WARN:snips_tts_hermes::pico: No language provided using default en-GB
Jun 09 10:16:15 HomeServer snips-tts[804]: WARN:snips_tts_hermes::pico: No language provided using default en-GB
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

● snips-audio-server.service - Snips Audio Server
   Loaded: loaded (/lib/systemd/system/snips-audio-server.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2019-06-08 16:26:49 BST; 17h ago
 Main PID: 800 (snips-audio-ser)
   Memory: 4.3M
      CPU: 47min 38.899s
   CGroup: /system.slice/snips-audio-server.service
           └─800 /usr/bin/snips-audio-server

Jun 09 10:09:16 HomeServer snips-audio-server[800]: Expression 'PaAlsaStream_Configure( stream, inputParameters, outputParameters, sampleRate, framesPerBuffer, &inputLatency, &outputLatency, &hostBufferSizeMode )' failed in 'src/hostapi/
Jun 09 10:09:16 HomeServer snips-audio-server[800]: thread 'portaudio.player' panicked at 'called `Result::unwrap()` on an `Err` value: "SendError(..)"', ERROR:snips_audio_server_hermes  : could not play "fb65374d-dbbd-4999-8898-01a4e42a
Jun 09 10:09:16 HomeServer snips-audio-server[800]:  -> caused by: InvalidSampleRate
Jun 09 10:09:16 HomeServer snips-audio-server[800]: src/libcore/result.rs:997:5
Jun 09 10:16:15 HomeServer snips-audio-server[800]: INFO:snips_audio_portaudio      : Playing "fe94be74-f783-4a67-8e71-a9da88e3c91f" using output "bcm2835 ALSA: IEC958/HDMI (hw:0,1)", wav spec: WavSpec { channels: 1, sample_rate: 16000,
Jun 09 10:16:15 HomeServer snips-audio-server[800]: Expression 'paInvalidSampleRate' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 2043
Jun 09 10:16:15 HomeServer snips-audio-server[800]: Expression 'PaAlsaStreamComponent_InitialConfigure( &self->playback, outParams, self->primeBuffers, hwParamsPlayback, &realSr )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 2717
Jun 09 10:16:15 HomeServer snips-audio-server[800]: Expression 'PaAlsaStream_Configure( stream, inputParameters, outputParameters, sampleRate, framesPerBuffer, &inputLatency, &outputLatency, &hostBufferSizeMode )' failed in 'src/hostapi/
Jun 09 10:16:15 HomeServer snips-audio-server[800]: thread 'portaudio.player' panicked at 'called `Result::unwrap()` on an `Err` value: "SendError(..)"', src/libcore/result.rs:997:5ERROR:snips_audio_server_hermes  : could not play "fe94b
Jun 09 10:16:15 HomeServer snips-audio-server[800]:  -> caused by: InvalidSampleRate

● snips-hotword.service - Snips Hotword
   Loaded: loaded (/lib/systemd/system/snips-hotword.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2019-06-08 16:26:50 BST; 17h ago
 Main PID: 814 (snips-hotword)
   Memory: 5.1M
      CPU: 40min 14.417s
   CGroup: /system.slice/snips-hotword.service
           └─814 /usr/bin/snips-hotword

Jun 09 10:09:16 HomeServer snips-hotword[814]: INFO:snips_hotword_hermes        : Hotword detected: site_id:living_room model:default (43ms ago)
Jun 09 10:09:16 HomeServer snips-hotword[814]: INFO:snips_hotword_lib::audio    : Audio thread for site living_room stopped.
Jun 09 10:09:31 HomeServer snips-hotword[814]: INFO:snips_hotword_lib::audio    : Audio thread for site living_room started.
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

Please any help anyone on this?

Sry, was off a few days…

Invalid sample in the audio. You need to add the rate in your asound.conf, on the output add rate 16000

Many thanks boss,

Though that wasn’t the issue, but it was an important pointer to what was the problem.

I had not created the asound.conf file, created it and all good now :slight_smile:

Kind regards

Great, happy it works for you!