ASR training is taking forever


#1

Hi,

I used Snips NLU for my project which was working perfectly fine for last 15 days. Now after adding some utterances in snips console, I tried to update the assistant using sam update-assistant, NLU training was done but ASR training was loading for long time without any error and assistant was not downloaded. I did sam update, yet no progress. Save me from this, please!

Thanks in advance


#2

Hello @Harini,

If Sam hangs up during the ASR training. It could be for multiple reasons. (We are updating our server, ASR has hung up due to an internal error, etc…)

First: try sam update-assistant again.
If it fails or just hangs up each time, try downloading the assistant directly from https://console.snips.ai
You can send the zip to your pi with sam install assistant -p path/to/your/assistant.zip

If the training also fails on the console please ping me again here with your assistant project id (proj_xxxx) that can be found in the console’s url bar when you have your assistant open.

Best regards,


#3

Hi Charles, thanks for reaching out. I tried sam install assistant -p /path/to/…zip, assistant got installed. But when I run sam status, snips services are not running. Refer screenshot.


#4

Hello @Harini,

Snips-audio-server is not up to date, version should be 0.60.8 like the rest of the services.

• First update the platform:
sudo apt-get update; sudo apt-get upgrade -y snips-platform-voice
• Then relaunch all services:
sudo systemctl restart snips-*
• Also don’t forget to update sam with npm install -g snips-sam
• Check if the audio is working: journalctl -f -u snips-audio-server to see the logs / resetup the/etc/asound.conf file with sam setup audio, test your microphone with sam test microphone
• Assistant could be outdated, but since you just downloaded a new one it should not be an issue.
• Check if other services are failing with sam status and check their logs journalctl -f -u name-of-snips-service


#5

Hi @Charles

Exactly followed every steps. Yet the problems still exists,

  1. Couldn’t download assistant through sam install assistant , ASR training is not completing
  2. Downloaded assistant through sam install assistant - p /path/to/assistant, but sam services are not running.
    Below is the screen shot of sam status

This is screen shot of snips services status

The assistant was perfect till last week. Wondering what went wrong.

Thanks.


#6

My guess is that the ASR training is failing on your assistant. Check in your assistant file if you have a folder named assistant/custom_asr/ and if the folder contains something.

Also try to launch the services with more verbose logs, kill snips-nlu service:
sudo systemctl stop snips-nlu
Launch it manually with verbose logs:
snips-nlu -vvv
Do the same with snips-asr

Then copy paste it here or on pastebin if its too long.

To reenable the services:
sudo systemctl start snips-nlu
sudo systemctl start snips-asr


#7

Just saw that sam status shows ASR engine: none so it’s definitely the ASR model not present that is causing an issue.
Do you use Snips’ ASR or Google ASR or no ASR at all ? You can select this option in the settings of your assistant in the console.


#8

You are life saver @Charles. custom_asr was missing. It is working now. Thanks a ton! :slight_smile: