Change voice feedback to german


#1

Hello snips community,
I just started creating an own assistant.
It is fetching data out of my home automation system (openhab) and is sending back the answer via mqtt to snips.
This is all working well beside the fact that snips is talking in english.
All my German responses have a very heavy english accent.

How can I change my tts module to use german pronunciation?

In general: Are there other voices available for the tts module? The default snips voice is not very nice :frowning:

Thank you very much in advance.

Best regards,
Matthias


#2

Is your assistant set to german in the console?

anyways I’ll just leave this here:


#3

Hello Philipp,
Thank you very much for that script! Will give it a try.
Yes, my assistant is set to German.
But what has the assistant to do with the reply that I send via mqtt?
I thought this setting (in the assistant) will only change the way the spoken language will be interpreted?
Think there has to be a general language setting for tts.

Thank you and best regards,
Matthias


#4

yes but snips automatically takes german as language for picotts when your assistant is in german, which usually kind of makes sense :wink:


#5

Is there a way to check this setting?
As mentioned, my assistant is German but the tts sound English.

Thank you in advance.

BR
Matthias


#6

Do not know why and how, but since the last reboot of my system snips is talking German.
Nevertheless, thanks for all your support.


#7

@64matze: I have read your post and found it very interessting that you use snips with openhab. would you mind sharing some details of your setup. I’m also using openhab and really would like to integrate snips.
Thank you!


#8

Do you have specific questions?
Maybe I will create a topic in “Your Projects” section for the general connection.


#9

Here you go
:grin: