Connect snips to hass.io mqtt broker


#21

Here is what i found in syslog:

Jan 22 06:25:50 snips_master systemd[1]: Stopped Snips ASR.
Jan 22 06:25:50 snips_master systemd[1]: Started Snips ASR.
Jan 22 06:25:50 snips_master systemd[1]: snips-asr.service: Main process exited, code=killed, status=4/ILL
Jan 22 06:25:50 snips_master systemd[1]: snips-asr.service: Unit entered failed state.
Jan 22 06:25:50 snips_master systemd[1]: snips-asr.service: Failed with result 'signal'.
Jan 22 06:25:56 snips_master systemd[1]: snips-asr.service: Service hold-off time over, scheduling restart.

Do you happen to know what that means?

Found something in regards to sample rate of the sound but i am not sure if thats it or if i can change that…


#22

I think i got it… my assistant was broken. I created a new one and all the services are starting up.
Nevertheless i still have the same error from the beginning:

[20:08:51] Watching on localhost:1883 (MQTT)
[20:08:57] [Hotword] detected on site default, for model hey_snips
[20:08:57] [Asr] was asked to stop listening on site default
[20:08:57] [Hotword] was asked to toggle itself 'off' on site default
[20:08:57] [Dialogue] session with id '5453fc8b-90fe-4f70-9f10-f0d0b9c8620f' was started on site default
[20:08:57] [AudioServer] was asked to play a wav of 41.1 kB with id 'a172148e-348a-4442-883b-47c4a3094651' on site default
[20:08:57] [AudioServer] finished playing wav with id 'a172148e-348a-4442-883b-47c4a3094651'
[20:08:57] [Asr] was asked to listen on site default
[20:09:13] [Dialogue] session with id '5453fc8b-90fe-4f70-9f10-f0d0b9c8620f' was ended on site default. The session was ended because one of the component didn't respond in a timely manner
[20:09:13] [Asr] was asked to stop listening on site default
[20:09:13] [Hotword] was asked to toggle itself 'on' on site default

HomeAssistant receives the following:

1548184135: Received PINGREQ from snips
1548184135: Sending PINGRESP to snips
1548184137: Received PUBLISH from snips (d0, q0, r0, m0, 'hermes/hotword/default/detected', ... (215 bytes))
1548184137: Received PUBLISH from snips (d0, q0, r0, m0, 'hermes/asr/stopListening', ... (71 bytes))
1548184137: Received PUBLISH from snips (d0, q0, r0, m0, 'hermes/hotword/toggleOff', ... (71 bytes))
1548184137: Received PUBLISH from snips (d0, q0, r0, m0, 'hermes/asr/startListening', ... (92 bytes))
1548184153: Received PUBLISH from snips (d0, q0, r0, m0, 'hermes/asr/stopListening', ... (37 bytes))
1548184153: Received PUBLISH from snips (d0, q0, r0, m0, 'hermes/hotword/toggleOn', ... (37 bytes))

Update:

i was wrong it is still not starting when the raspberry is rebooted. :frowning: