Could not find a version that satisfies the requirement hermes-python

#1

When running: sudo ./setup.sh
I got this:

Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting hermes-python>=0.2 (from -r requirements.txt (line 2))
Could not find a version that satisfies the requirement hermes-python>=0.2 (from -r requirements.txt (line 2)) (from versions: 0.1.24)
No matching distribution found for hermes-python>=0.2 (from -r requirements.txt (line 2))

Installing the assistant in different ways still lead to the same error.
Thanks for the help.

#2

That’s way too little information for us to help you. Which app are you installing? What system is this on? What “different ways” of installing lead to the same error?

But you shouldn’t use sudo ./setup.sh to install Snips apps, because they are installed as root then. The apps are installed in /var/lib/snips/skills, which is owned by user _snips-skills. You have to make sure that all files in this directory are owned by the same user.

The easiest way to do this is one of these two ways:

  • sam install skills
  • sudo -u _snips-skills snips-skill-server install_skills
#3

I just ended up to format and start all over again. Working now. I was using it on raspberry 2. I believe it was something related with pip version. Thanks anyway.

#4

The Raspberry Pi 2 is not supported.

#5

What do you mean raspberry 2 is not supported? I’m using Raspberry 2B and it’s working

#6

For the full platform, the hardware recommendations state that you need a Raspberry Pi 3.

On satellites, you can use any Raspberry Pi, even a Pi Zero.

#7

Hi @NBatalha,
I think it was due to a deprecated version of pip that you were using !