Could not find required input device

#1

Newb here.
I am using a matrix creator and PI 3b+. I ran through this tutorial.

running sam test speaker / sam test microphone works and arecord / aplay works

running sam status always results in snips-audio-server showing (not running)

When I stop the service and then run
snips-audio-server -vv

I see the below message
[11:20:05.741555] DEBUG:snips_audio_portaudio : Portaudio: Ok(“PortAudio V19-devel (built Mar 20 2019 09:16:54)”)
[11:20:05.741777] DEBUG:snips_audio_portaudio : Looking for input device called MATRIXIO SOUND: - (hw2,0)
[11:20:05.741867] DEBUG:snips_audio_portaudio : Consider: bcm2835 ALSA: - (hw:0,0)
[11:20:05.741924] DEBUG:snips_audio_portaudio : Consider: bcm2835 ALSA: IEC958/HDMI (hw:0,1)
[11:20:05.741981] DEBUG:snips_audio_portaudio : Consider: Dummy: PCM (hw:1,0)
[11:20:05.742034] DEBUG:snips_audio_portaudio : Consider: MATRIXIO SOUND: - (hw:2,0)
[11:20:05.742086] DEBUG:snips_audio_portaudio : Consider: MATRIXIO SOUND: - (hw:2,1)
[11:20:05.742140] DEBUG:snips_audio_portaudio : Consider: sysdefault
[11:20:05.742194] DEBUG:snips_audio_portaudio : Consider: dmix
[11:20:05.742248] DEBUG:snips_audio_portaudio : Consider: default
[11:20:05.743009] DEBUG:snips_audio_portaudio : Mike source capture ended
[11:20:05.746633] DEBUG:snips_audio_portaudio : Attempt 1
[11:20:05.746862] ERROR:snips_audio_server : Could not find required input device

My snips.toml file looks like
mike = “MATRIXIO SOUND: - (hw2,0)”

Any help is greatly appreciated!

1 Like
#2

Hello, I have exactly the same problem as you.
If you can solve it, please let him know.
If I find the answer first, I’ll let you know
Thank you. :slight_smile:

#3

I ran into this issue setting it up on my machine. What is the output of arecord -l?
Mine looks like this:

**** List of CAPTURE Hardware Devices ****
card 1: MATRIXIOSOUND [MATRIXIO-SOUND], device 0: matrixio.mic.0 snd-soc-dummy-dai-0 []
Subdevices: 0/1
Subdevice #0: subdevice #0

Notice the square brackets? Put what’s in the square brackets in the /etc/snips.toml mike section. And the hw address should 2,0 if your arecord -l says card 2. I edited my /etc/asound.conf and commented out the snd-dummy line in the /etc/modules-load.d/matrix-mics.conf file. That’s why my matrix shows up as 1.

Good luck!

#4

I ended up finding the solution on my own, I mail it hoping it will help someone…
I wrote solution in another post :

In the/etc/Snips.toml file,

DO NOT WRITE:

mike = “MATRIXIO SOUND: - (Hw:2.0)”

But:

mike = “MATRIXIO-SOUND: - (Hw:2.0)”

I wish you a good continuation,
Tengu.