Custom Hotword works once then fails


#1

Hi all.
Ive been checking for help on the forum, but my errors seems to differ from what others have posted.

I followed this procedure to customize my Hotword:
https://docs.snips.ai/guides/advanced-configuration/wakeword/personal-wakeword

With some success.
Worked well. First test with new Hotword worked, then no more hotword recognition.

issued a sam reboot.
After reboot, first attempt with new custom hotword works, then it dies again.

I get this error after first working attempt:

[Asr] was asked to stop listening on site default

Ive seen this error in a couple of post, but no clear FIX.

Any help would be great!

Running:
Rpi3
OS version … Raspbian GNU/Linux 9 (stretch)
snips-asr … 0.60.10 (running)
snips-audio-server … 0.60.10 (running)
snips-dialogue … 0.60.10 (running)
snips-hotword … 0.60.10 (running)
snips-nlu … 0.60.10 (running)
snips-skill-server … 0.60.10 (running)
snips-tts … 0.60.10 (running)

Thx alot!


#2

That’s not an error. Check your syslog to see if there’s anything


#3

You are righ. I do see this message when working correctly with Hey-Snips.

Will check /var/log/syslog

standby.


#4

Here is my syslog… Kinda weird is that at boot, I hear the sound as-if the hotword was spoken…
Then not working anymore… Here is this syslog:

Jan 7 16:47:14 raspberrypi snips-hotword[511]: INFO:snips_hotword_hermes : Hotword detected: site_id:default model:moanaV1 (49ms ago)
Jan 7 16:47:14 raspberrypi snips-dialogue[504]: INFO:snips_dialogue_lib::coordinator::coordinator: Site [default]: reset site -> turn off ASR and turn off Hotword
Jan 7 16:47:14 raspberrypi snips-dialogue[504]: INFO:snips_dialogue_lib::coordinator::coordinator: Session [9801cbf7-e39d-4531-9284-63fc806db1f4]: The session has been created because the site “default” is free
Jan 7 16:47:14 raspberrypi snips-audio-server[1212]: INFO:snips_audio_portaudio : Playing “b3587175-6a99-4301-ba99-c8ec5263c201” using output “default”, wav spec: WavSpec { channels: 2, sample_rate: 22050, bits_per_sample: 16, sample_format: Int }
Jan 7 16:47:14 raspberrypi snips-hotword[511]: INFO:snips_hotword_lib::audio : Audio thread for site default stopped.
Jan 7 16:47:14 raspberrypi snips-audio-server[1212]: INFO:snips_audio_portaudio : Playing of “b3587175-6a99-4301-ba99-c8ec5263c201” finished
Jan 7 16:47:14 raspberrypi snips-tts[507]: WARN:snips_tts_hermes : Received a “play finished” message from audio server with an unknown id ‘b3587175-6a99-4301-ba99-c8ec5263c201’. It could be normal if you have more than one audio server.
Jan 7 16:47:14 raspberrypi snips-asr[508]: INFO:snips_asr_hermes : Listening
Jan 7 16:47:14 raspberrypi snips-asr[508]: INFO:snips_asr_lib::asr : T0 entered AsrRunner::run
Jan 7 16:47:14 raspberrypi snips-asr[508]: INFO:snips_asr_lib::asr : T0+0.000 capture started

Jan 7 16:47:21 raspberrypi snips-asr[508]: INFO:snips_asr_lib::asr : T0+6.515 endpoint detected (rule:1) frame:273 samples:69888 signal_time:4.368 rtf:1.403
Jan 7 16:47:21 raspberrypi snips-asr[508]: INFO:snips_asr_lib::asr : Source thread stop on push: “Full(…)”
Jan 7 16:47:21 raspberrypi snips-asr[508]: INFO:snips_asr_lib::asr : T0+6.519 capture ended

Jan 7 16:47:21 raspberrypi snips-asr[508]: INFO:snips_asr_lib::asr : T0+6.730 decoder finalized
Jan 7 16:47:21 raspberrypi snips-asr[508]: INFO:snips_asr_lib::asr : T0+6.757 lookup and post-processing done
Jan 7 16:47:21 raspberrypi snips-asr[508]: INFO:snips_asr_lib::asr : decoded: [Recognition { decoded_string: “”, likelihood: 0.0, tokens: Some([]) }]
Jan 7 16:47:21 raspberrypi snips-asr[508]: INFO:snips_asr_hermes : Cleanup
Jan 7 16:47:21 raspberrypi snips-asr[508]: INFO:snips_asr_hermes : Preparing decoder
Jan 7 16:47:21 raspberrypi snips-audio-server[1212]: INFO:snips_audio_portaudio : Playing “8ed689a1-4b21-4aac-ae7f-76e940ce5902” using output “default”, wav spec: WavSpec { channels: 2, sample_rate: 22050, bits_per_sample: 16, sample_format: Int }
Jan 7 16:47:22 raspberrypi snips-asr[508]: INFO:snips_asr_hermes : Idle

Jan 7 16:47:22 raspberrypi snips-audio-server[1212]: INFO:snips_audio_portaudio : Playing of “8ed689a1-4b21-4aac-ae7f-76e940ce5902” finished
Jan 7 16:47:22 raspberrypi snips-tts[507]: WARN:snips_tts_hermes : Received a “play finished” message from audio server with an unknown id ‘8ed689a1-4b21-4aac-ae7f-76e940ce5902’. It could be normal if you have more than one audio server.
Jan 7 16:47:22 raspberrypi snips-audio-server[1212]: INFO:snips_audio_portaudio : Playing “0e17bfe7-c8b5-4d86-8af8-e02c564c4fac” using output “default”, wav spec: WavSpec { channels: 2, sample_rate: 44100, bits_per_sample: 16, sample_format: Int }
Jan 7 16:47:23 raspberrypi snips-audio-server[1212]: INFO:snips_audio_portaudio : Playing of “0e17bfe7-c8b5-4d86-8af8-e02c564c4fac” finished
Jan 7 16:47:23 raspberrypi snips-tts[507]: WARN:snips_tts_hermes : Received a “play finished” message from audio server with an unknown id ‘0e17bfe7-c8b5-4d86-8af8-e02c564c4fac’. It could be normal if you have more than one audio server.
Jan 7 16:47:23 raspberrypi snips-dialogue[504]: INFO:snips_dialogue_lib::coordinator::coordinator: Session [9801cbf7-e39d-4531-9284-63fc806db1f4]: closing session which was active: IntentNotRecognized
Jan 7 16:47:23 raspberrypi snips-dialogue[504]: INFO:snips_dialogue_lib::coordinator::coordinator: Site [default]: reset site -> turn off ASR and turn on Hotword
Jan 7 16:47:23 raspberrypi snips-hotword[511]: INFO:snips_hotword_lib::audio : Audio thread for site default started.

After this, nothing…

Thx alot all!


#5

Anyone had this issue?


#6

Hello,

Can you just do this :
sudo systemctl stop snips-hotword

and after, start snips-hotword at commandline :
snips-hotword

Eventually with -vv

An put the log after say yout hotword twice.

Ced


#7

Same problem here.
Also from command line it works only once:

root@raspberrypi:/usr/share/snips# snips-hotword --model /etc/snips/personal_2019_03_20T11_19_54                                                                                                                  
[12:12:09.056958] INFO :snips_hotword::server: Using model from /etc/snips/personal_2019_03_20T11_19_54
[12:12:09.193580] INFO :snips_hotword::server: Discovered audio_server default/mqtt, starting hotword listener                                                                                                    
[12:12:09.193665] INFO :snips_hotword::server: Connecting using MQTT site-id default
[12:12:09.194105] INFO :snips_hotword_lib::audio: Audio thread for default started
[12:12:09.194433] INFO :snips_hotword_lib::audio: Net and VAD thread for site default started (vad inhibitor: true, vad messages: false                                                                           
[12:12:09.198432] INFO :snips_hotword_lib       : Detector "detector.hey rosetta.default", sensitivity: 0.9, threshold 0.100000024                                                                                
[12:12:09.198755] INFO :snips_hotword_lib       : detector.hey rosetta.default thread started
[12:12:11.762097] INFO :snips_hotword_hermes    : Hotword detected: site_id:default model:hey rosetta (42ms ago)                                                                                                  
[12:12:11.852012] INFO :snips_hotword_lib::audio: Audio thread for site default stopped.
[12:12:22.383048] INFO :snips_hotword_lib::audio: Audio thread for site default started.