Default in the Snips console

#1

I work with Snips to improve my home automation, and I have already solved a lot of trouble. I use a fork of the Jeedom assistant to simplify my debut, but I can not find the solution, because when after the hotword call, the assistant recognizes that I said: "turn off the light “instead of choosing the intent” TurnOffLights “, he chooses” TurnOffDevices "as intent. If I choose “turn off the light” he chooses the intent “TurnOnLights”. Moreover it seems to have a random side.
Do you have a track or topic to solve this problem ??? I think I read something, but I can not find it.
sometimes he even returns me “returnStateValue” …
Should we have a slot for the requested action like “open”, “close” or “off” for example ???
“turn on the light” or “turn off the light” gives good results, but not always …
And with the use of “LightShiftDown”, he recognizes “brightness” but not “light”.
Last question, To be sure that it works then in an Apps, it must already work in the Snips console ???

#2

Hello,

This is not really a console problem, more like an assistant training / design issue or nlu issue.

I would suggest you install the JeedomOfficial app published by SNIPS user to ensure that you have a good quality assistant.

Then you can try to reproduce the same input, and get the output. If it still has the issue, please let us know. (You can try this input and get result in the Snips Console as well, the right side debug area)

#3

Ok I will do like that, but how can I save the wizard that I already work to get it back, if it ever does not work better with the official Jeedom ??

#4

I deleted everything I did and I installed JeedomOfficiel by Valf, i ask ans I get this:
With the microphone in the console I get this:

“input”: “close the light”,
“slots”:

“rawValue”: “light”,
“value”:
“kind”: “Custom”,
“value”: “light”

“range”:
“start”: 10,
“end”: 17

“entity”: “device_name”,
“slotName”: “device_name”

“intent”:
“confidenceScore”: 1,
“intentName”: “valf:TurnOffJeedom”

Not “lightsTurnOffJeedom”

then:

“input”: “close the light”,
“slots”: [],
“intent”:
“confidenceScore”: 1,
“intentName”: “valf:lightsTurnOffJeedom”

So I get two different intents with the same request

Then with Snips in a Raspberry pi3, i get:

[Asr] captured text “close the light” in 2.0s
[16:28:32] [Asr] was asked to stop listening on site default
[16:28:32] [AudioServer] was asked to play a wav of 93.1 kB with id ‘8d9dadcd-9450-4819-a0a3-9ec9e78898d2’ on site default
[16:28:33] [AudioServer] finished playing wav with id ‘8d9dadcd-9450-4819-a0a3-9ec9e78898d2’
[16:28:33] [Nlu] was asked to parse input “close the light”
[16:28:33] [Nlu] detected intent valf:lightsTurnOffJeedom with confidence score 1.000 for input “close the light”
[16:28:33] [Dialogue] New intent detected valf:lightsTurnOffJeedom with confidence 1.000

and this:

[16:29:16] [Asr] captured text “close the light of the office” in 3.0s
[16:29:16] [Asr] was asked to stop listening on site default
[16:29:16] [AudioServer] was asked to play a wav of 93.1 kB with id ‘d6072af2-cd26-4342-9ee2-8d48dc2237a8’ on site default
[16:29:18] [AudioServer] finished playing wav with id ‘d6072af2-cd26-4342-9ee2-8d48dc2237a8’
[16:29:18] [Nlu] was asked to parse input “close the light of the office”
[16:29:18] [Nlu] detected intent valf:TurnOffJeedom with confidence score 1.000 for input “close the light of the office”
Slots ->
device_name -> light (confidence: 1.000)
house_room -> office(confidence: 1.000)
[16:29:18] [Dialogue] New intent detected valf:TurnOffJeedom

i don’t know how i must do this???
can you help me???

#6

Finally I answer myself:
The latest official version of the Jeedom snips wizard is JeedomOfficiel by Snips …
And there is much better …

And finally after some tests I discover some more bugs in the Jeedom wizard
With “off the desktop lights” I have “lightsTurnOffJeedom” and “confidenceScore”: 1,
With “closes the office light” I have “lightsTurnOffJeedom” and “confidenceScore”: 1, “how is the office light”,
With “how is the office light” I have “lightsSetJeedom” and “confidenceScore”: 0.27720845, with a low confidenceScore here.
And with “turn off the desktop light” I have “EntityStateValueJeedom” and “confidenceScore”: 1,

By dint of putting my nose in Snips Jeedom, I’m a little surprised that the words like “turn on” “off” “How” are not integrated into a slot that would allow I believe a more precise training … Someone may have more experience … ???

Before going further in development, I would like the assistant to have maximum reliability, before being able to rely on stable slots, which can send to my home automation variables reliable and with a stable structure, because I can not get my hands back in python with every problem discovered

#7

In the wizard training how do I practice that with “off the lights of the office” the wizard will return “lightsTurnOffJeedom” and “confidenceScore”: 1, not “EntityStateValueJeedom” and “confidenceScore”: 1 ,

It is obviously the word extinct which is not understood. If I use “shut the office light” I get “lightsTurnOffJeedom”

{
  "input": "off the desktop lights",
  "intent": {
    "intentName": "richardpub:EntityStateValueJeedom",
    "confidenceScore": 1
  },
  "slots": [
    {
      "rawValue": "light",
      "value": {
        "kind": "Custom",
        "value": "light"
      },
      "range": {
        "start": 10,
        "end": 17
      },
      "entity": "state_device_name_jeedom",
      "slotName": "object"
    },
    {
      "rawValue": "desktop ",
      "value": {
        "kind": "Custom",
        "value": "desktop "
      },
      "range": {
        "start": 21,
        "end": 27
      },
      "entity": "house_room_jeedom",
      "slotName": "house_room"
    }
  ]
}
#8

Hello there,

A bit confused, could you share the app link?

We’ve tested the French JeedomOfficial belonging to Snips which is the only official one you should use and we don’t have this issue.

#9

I did the test as recommended in French with JeedomOfficiel by Snips, then I just redo it to the new … to test it, I use the microphone or the typing on the keyboard, in the console and for “éteins la lumière du bureau” in French, I always get the following error:

{
  "input": "éteins la lumière du bureau",
  "intent": {
    "intentName": "EntityStateValueJeedom",
    "confidenceScore": 1
  },
  "slots": [
    {
      "rawValue": "lumière",
      "value": {
        "kind": "Custom",
        "value": "lumière"
      },
      "range": {
        "start": 10,
        "end": 17
      },
      "entity": "state_device_name_jeedom",
      "slotName": "object"
    },
    {
      "rawValue": "bureau",
      "value": {
        "kind": "Custom",
        "value": "bureau"
      },
      "range": {
        "start": 21,
        "end": 27
      },
      "entity": "house_room_jeedom",
      "slotName": "house_room"
    }
  ]
}

with “éteins les lumières du bureau” I have “lightsTurnOffJeedom”

I solved the problem by removing the intents of light from the assistant JeedomOfficiel and I imported the intents of the assistant “Lumière Connectée” from niveksema…

but I would prefer to use the official Jeedom Assistant not to multiply the origin of my assistant for my home automation version under Lifedomus.

#10

and with “comment est la lumière du bureau?” in french, i have:

Blockquote{
“input”: “comment est la lumière du bureau”,
“intent”: {
“intentName”: “lightsSetJeedom”,
“confidenceScore”: 0.18622772
},
“slots”: [
{
“rawValue”: “bureau”,
“value”: {
“kind”: “Custom”,
“value”: “bureau”
},
“range”: {
“start”: 26,
“end”: 32
},
“entity”: “house_room_jeedom”,
“slotName”: “house_room”
}
]
}

Do I have to validate all the items of the official jeedom application to check that all intents correspond to the use of home automation in my house??

#11

am i the only one to have encountered this problem with the official version snips jeedom ???
I go through a bypass but it does not make sense to me …