Error with actions since 0.60.12


#1

Hi,

I updated to 0.60.12, did a few assistant tuning and when doing sam update-assistant I got this:

ERROR:snips_template                    : Permission denied (os error 13)
Setting up Python actions
Running setup.sh & generating virtual environment for kiboost.DateAgeManips
✖ Error setting up virtualenv, one or more actions might not be able to run. Reason :
You are using pip version 18.1, however version 19.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

I did update pip:

pip --version
pip 19.0.1 from /usr/local/lib/python2.7/dist-packages/pip (python 2.7)

How can I fix that please ?


#2

PIP for python2 is called pip… and python3 is called pip

so what version is pip3 --version ? Is snips using python3 now and not python2 ?


#3

I’m having a similar problem:

✖ Error setting up virtualenv, one or more actions might not be able to run. Reason :
You are using pip version 18.1, however version 19.0.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

While I don’t have pip 18.1 installed as far as I know:

pi@hassbian:~ $ pip --version
pip 19.0.2 from /usr/local/lib/python2.7/dist-packages/pip (python 2.7)
pi@hassbian:~ $ pip3 --version
pip 9.0.1 from /usr/lib/python3/dist-packages (python 3.5)

EDIT: Found this: Problems installing the assistant on Raspberry Pi


#4

I was also facing the same problem. I have already installed all the dependencies. But still getting the errors.


#5

not a real error, just a warning: the app devs have to upgrade their apps to python 2.7 in the next year or… there will be no more support for it - but everything should still be working