Fresh installation of snips - 3 issues

I first used snips on a clean and fresh raspbian buster installation on a pi4, however I could not get it to detect the wake word.

I now did a reinstall on a raspberry pi 3b downgrading to raspbian stretch. I then did the installation gain (using sam), and now it is working. I have installed 2 apps from the store (weather and alarm clocks)

I have, however, 3 issues:

  • I cannot record my own hotword, the script keeps complaining about too much noise (see last post here)

  • The TTS audio playback seems to cut off snips responses some times. E.g. if I ask for the weather, audio stops playing before the full response has been spoken

  • I have to set sound_feedback_disabled_default to true, otherwise, after detecting the hotword, snips will not continue, but instead abort after a while, complaining that something did not complete. I guess it is trying to play the feedback .wave file, but it wont play, so that the processing chain gets blocked.

I should have a rather standard setup (raspberry pi 3b, raspbian stretch), but the sound cut off is really a no-go. The other to issues are bad, but not a must have.

Does anyone know if those are known issues, and how I can fix them?

Looks like something is wrong with the sound config?

E.g. ALSA is sound card, unknown PCM cards and it couldnt find and ffmpeg is a codec which it couldnt find probaly to do with audio as well.

There was some configuration settings that fixed mine here:

Maybe give that a whirl…

I did a reinstall of the whole pi, downgrading to raspbian stretch. I then did the same installation gain (using sam), and now it is working.

I have, however, 3 issues:

  • I cannot record my own hotword, the script keeps complaining about too much noise (see last post here)

  • The TTS audio playback seems to cut off snips responses some times. E.g. if I ask for the weather, audio stops playing before the full response has been spoken

  • I have to set sound_feedback_disabled_default to true, otherwise, after detecting the hotword, snips will not continue, but instead abort after a while, complaining that something did not complete. I guess it is trying to play the feedback .wave file, but it wont play, so that the processing chain gets blocked.

I should have a rather standard setup (raspberry pi 3b, raspbian stretch), but the sound cut off is really a no-go. The other to issues are bad, but not a must have.

Does anyone know if those are known issues, and how I can fix them?

I was able to solve all 3 issues by doing the following:

  • download an older image of raspbian stretch lite with linux kernel 4.14.
  • replace the matrix voice microphone with a respeaker mic array v2, as the latter is connected via USB and just works, while the matrix requires a separate kernel module which will not compile with a 4.14 kernel
  • install snips using sam as I did before

The feedback sounds now work, recording hotword works, and I have no sound cut offs.

As can be read in other forum posts, there seems to be issues with kernel 4.19 which also affect snips. A common workaround seems to be to add Environment=“PA_ALSA_PLUGHW=1” to /etc/snips.toml in the snips-audio-server section, however I haven’t tested this.