Google ASR can't train

Hello,

I am trying to setup google ASR and I am facing this error:
$ sam update-assistant
Updating assistant

NLU training done 
✖ Unable to install the assistant: {"message":"bad request: assistant proj_VGgK7EwXY2M with ASR 'google' can't train ASR","status":"error"}

In order to switch from Snips ASR to google ASR I have followed this setup procedure
https://docs.snips.ai/articles/raspberrypi/manual-setup#configuring-the-automatic-speech-recognition-asr-engine.
Switching back to Snips ASR works fine.
When I run /usr/bin/snips-asr-google from command line, it connects to MQTT with no errors but recognition does not work.
Output of sam status fo reference:
Connected to device raspberrypi

OS version ................... Raspbian GNU/Linux 9 (stretch)
Installed assistant .......... domov
Language ..................... en
Hotword ...................... chappie
ASR engine ................... snips
Status ....................... Live

Service status:

snips-analytics .............. (not running)
snips-asr .................... 0.63.3 (not running)
snips-audio-server ........... 0.63.3 (running)
snips-dialogue ............... 0.63.3 (running)
snips-hotword ................ 0.63.3 (running)
snips-nlu .................... 0.63.3 (running)
snips-skill-server ........... 0.63.3 (running)
snips-tts .................... 0.63.3 (running)

Would you please suggest how to fix this?
What I am trying to achieve is to have voice assistant supporting czech language.
Thank you in advance.
Honza

I found out that when I change ASR setting manually in assistant.json to “google”, it actually works with google. However “sam update-assistant” still fails as described above.

I confirm that problem. I had to change ASR PROVIDER to Snips On-Device ASR to deploy assistant on my device.