Howto install on arm64?


#1

Hi there !
I’ve installed a debian stretch on an arm64 box, within lxc (this part should not be a problem)
I followed the instructions about installing on rapsberry, but of course, I did failed on apt update , which throws :
N: Skipping acquire of configured file 'main/binary-arm64/Packages' as repository 'https://raspbian.snips.ai/stretch stable InRelease' doesn't support architecture 'arm64'

I also tried to install snips-nlu under pyhton :
sudo python3 -m pip install snips-nlu
which fails with :
Could not find a version that satisfies the requirement snips-nlu-parsers<0.3,>=0.2 (from snips-nlu) (from versions: 0.1.1, 0.1.2) No matching distribution found for snips-nlu-parsers<0.3,>=0.2 (from snips-nlu)

My uname -a says :
Linux snips 4.20.5-aml-s905 #5.76 SMP PREEMPT Sun Feb 24 16:37:53 MSK 2019 aarch64 GNU/Linux
It says aarch64 (so, should I use https://raspbian.snips.ai/410c_linaro_buster source ?), but the debian architecture says arm64 ?

Should I compile everything from source ? if so, is there a tutorial somewhere ? I didn’t found it !

Thanks !!


#2

Definitely following it. I found something similar on 192.168.0.1 username and password by routerlogin but couldn’t say if it was helpful for the arm64 installation.


#3

Hi @napo7 we have some intructions on how to install on an amd64 box here: https://docs.snips.ai/articles/other-platforms/linux-amd64


#4

Hi @fredszaq
Thanks for you reply, but it’s not AMD64 but ARM64 ! :wink:

Edit : After some research, it seems that my ARM64 environment is able to run 32 bits containers.
So my idea (to be tested…) is to run a container on armhf environment… I’ll keep you in touch !


#5

arf @napo7 I read too fast :smiley: you can try with the 410c_linaro_buster repo, it may work (but I don’t give any guaranties)

arm64 == aarch64 in most cases

running in and armhf env can be a solution too, I think a few persons managed to get it running

for the snips-nlu python package, you can try and compile it from source, more info here : https://github.com/snipsco/snips-nlu#installation


#6

arm64 == aarch64
add repo this below
i try however snips-audio-server has error “noDevice” even with snips maker hardware

sudo bash -c ‘echo “https://raspbian.snips.ai/410c_linaro_buster stable main” > /etc/apt/sources.list.d/snips.list’


#7

Just a follow up :
I did not tried the aarch64 repo, but instead, on my machine I setup an lxc container on armhf architecture.
I don’t see any issues of doing so. I was already setting an LXC container for snips, so choosing armhf instead of arm64 is not a problem.

Now, I muse have a look on how to setup remote microphones, and use the “server” for processing.


#8

I might want to try this approach rather than running aarch64 snips on arm64 ubuntu since lots of snips-skill incompatible on arm64
Can you give some guideline how to setup 32-bit container?