Install on debian 9 VM

Here the result :

snips-analytics install
snips-asr install
snips-audio-server install
snips-dialogue install
snips-hotword install
snips-kaldi-atlas install
snips-nlu install
snips-platform-common install
snips-platform-voice install
snips-skill-server install
snips-template install
snips-tts install

And result of sam status after :

snips-analytics … 0.60.1 (not running)
snips-asr … 0.60.1 (not running)
snips-audio-server … 0.60.1 (not running)
snips-dialogue … 0.60.1 (not running)
snips-hotword … 0.60.1 (not running)
snips-nlu … 0.60.1 (not running)
snips-skill-server … 0.60.1 (not running)
snips-tts … 0.60.1 (not running)

So I installed my assistant and here the status

snips-analytics … 0.60.1 (running)
snips-asr … 0.60.1 (running)
snips-audio-server … 0.60.1 (not running)
snips-dialogue … 0.60.1 (running)
snips-hotword … 0.60.1 (running)
snips-nlu … 0.60.1 (running)
snips-skill-server … 0.60.1 (not running)
snips-tts … 0.60.1 (not running)

So I haven’t audi on this VM so I guess audio-server and tts off are normal, but what about skill-server ?

you now just need to start the snips-skill-server … and enable it so it start after each reboot

sudo systemctl enable snips-skill-server
sudo systemctl start snips-skill-server

Still not running. No messages from sudo systemctl enable snips-skill-server or sudo systemctl start snips-skill-server.

you will have more output with sudo journalctl -u snips-skill-server … you can also watch the /var/log for the error message …

the issue is now : how to manually install and configure a skills without sam

Here the message inside journalctl :

nov. 11 15:55:46 snips systemd[1]: snips-skill-server.service: Main process exited, code=exited, status=1/FAILURE
nov. 11 15:55:46 snips systemd[1]: snips-skill-server.service: Unit entered failed state.
nov. 11 15:55:47 snips systemd[1]: snips-skill-server.service: Failed with result ‘exit-code’.
nov. 11 15:55:52 snips systemd[1]: snips-skill-server.service: Service hold-off time over, scheduling restart.
nov. 11 15:55:52 snips systemd[1]: Stopped Snips Skill Server.
nov. 11 15:55:52 snips systemd[1]: Started Snips Skill Server.
nov. 11 15:55:52 snips snips-skill-server[101877]: ERROR:snips_skill_server: failed to fetch skills
nov. 11 15:55:52 snips snips-skill-server[101877]: -> caused by: didn’t find any skills in root skills directorie(s)

I try the same thing today and facing the same error. Simply, it says, that no skills are installed. Unfortunately i have no idea how to install them manually…

But i figured out a procedure, how to install the “snips core” manually and the assistant with sam!
The important point is that you NOT use sam init! Because it change the apt repository to https://raspbian.snips.ai/... and that’s wrong on Debian. Maybe it’s not the only wrong one…

However, you have to do all the things, that sam init do, manually. The following procedure works for me on a fresh and clean Debian 9 minimal.

su
apt update && apt install sudo
usermod -aG sudo <username>
echo 'username ALL=(ALL) NOPASSWD: ALL' | sudo tee --append /etc/sudoers > /dev/null

#Logout and login as <username>

sudo apt update && sudo apt dist-upgrade
sudo apt-get install -y dirmngr apt-transport-https
sudo apt-add-repository non-free
sudo bash -c  'echo "deb https://debian.snips.ai/stretch stable main" > /etc/apt/sources.list.d/snips.list'
sudo apt-key adv --keyserver pgp.mit.edu --recv-keys F727C778CCB0A455
sudo apt update
sudo apt install -y alsa-utils snips-platform-voice snips-skill-server snips-watch curl unzip
sudo sudo usermod -aG snips-skills-admin <username>

#Logout and login

curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash -
sudo apt-get install -y nodejs
sudo alsactl init
sudo npm install -g snips-sam
sam connect localhost
sam login
sam install assistant
sudo systemctl restart 'snips-*'
1 Like

Oh god thank a lot !!

Every services are installed, only audio server isn’t running, I guess it’s because it’s a VM without microphone / speaker.

Are you going to use satellites with configuration A or B ?

Thank again you save me :slight_smile:

Nice that I could help you!

Your are right, the audio server service won’t start without a sound card. Since it is a VM, you can simply add a sound card independently of you have really connect a microphone / speaker.

My goal is to set up the satellites configuration B. The Server run as VM (or even better as a Docker container) and the satellites are raspberry pi’s running with DietPi as operating system.

So the next step is the satellite configuration. I hope i find the next days time to do it.
Of curse, i will share my results with you!

Hi

I have the same goal as you, I already try to install satellite but it doesn’t trigger my VM at the moment :confused:

Hi ! I just installed snips server on Debian VM. Did you solve the connection issue with satellite (B) ?
Which platform do you use for the satellite?
Regards

Hi

I use a rpi3 with a respeaker pi-hat for satellite.

Hi ! Did you solve the connection issue ? does the satellite work ?
Thx

Not currently, I didn’t have time to install satellite with A configuration for testing.

My satellites work, but only as configuration method A. The strange thing is, that i have do all steps for configuration method B… I will investigate this issue as soon as possible.

Same problem for you, no detection with configuration B ?

I think it’s better to talk about this problem in the separate thread that you have created. -> https://forum.snips.ai/t/satellite-type-b-no-detection/777/21

Hi

Me again :confused:

I install snips server on a Workstation virtual machine (I was using hyper-v before).

Everything works with commands from @david195 except snips-tts doesn’t install.

When I try to install it manually with sudo apt-get install -y snips-tts it says that libttspico-utils can’t be installed.

And when I try to install libttspico-utils it says that no versions can be installed.

So why it worked before on hyper-v and not anymore with workstation ? I change nothing on my Debian installation process.

Thank for your help…again

Hi Hydro!

‘libttspico-utils’ is a ‘non-free’ package. Simply add ‘non-free’ after ‘main’ in your sources.list. See: https://wiki.debian.org/SourcesList

I already added non-free :

As expected, everything seem to work except TTS return :frowning: