Install on debian 9 VM


#21

Hi

Me again :confused:

I install snips server on a Workstation virtual machine (I was using hyper-v before).

Everything works with commands from @david195 except snips-tts doesn’t install.

When I try to install it manually with sudo apt-get install -y snips-tts it says that libttspico-utils can’t be installed.

And when I try to install libttspico-utils it says that no versions can be installed.

So why it worked before on hyper-v and not anymore with workstation ? I change nothing on my Debian installation process.

Thank for your help…again


#22

Hi Hydro!

‘libttspico-utils’ is a ‘non-free’ package. Simply add ‘non-free’ after ‘main’ in your sources.list. See: https://wiki.debian.org/SourcesList


#23

I already added non-free :


#24

As expected, everything seem to work except TTS return :frowning:


#25

Ok sources.list looks good.
Please post the output from snips-tts -vvv and sudo apt-cache show libttspico-utils.


#26

snips-tts -vvv : commande not found

sudo apt-cache show libttspico-utils : Impossible de choisir les versions du paquet « libttspico-utils » qui n’est qu’un paquet virtuel
N: Aucun paquet n’a été trouvé

Sorry in French :confused:

Thank for your help !


#27

Ok, both packages are missing.
Can you also post the output from sudo apt-get update && sudo apt-get install snips-tts and sudo apt-get update && sudo apt-get install libttspico-utils ?


#28

Ok here the result :

hydro@Snips:~$ sudo apt-get update && sudo apt-get install snips-tts and sudo apt-get update && sudo apt-get install libttspico-utils
Atteint:1 http://security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://ftp.fr.debian.org/debian stretch InRelease
Atteint:3 http://ftp.fr.debian.org/debian stretch-updates InRelease
Atteint:4 http://ftp.fr.debian.org/debian stretch Release
Atteint:5 https://deb.nodesource.com/node_8.x stretch InRelease
Atteint:7 https://debian.snips.ai/stretch stable InRelease
Lecture des listes de paquets… Fait
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
E: Impossible de trouver le paquet apt-get
E: Impossible de trouver le paquet update


#29

Oh, copy and paste a little bit too much :wink: Please run sudo apt-get update && sudo apt-get install snips-tts first and post the output, then run sudo apt-get update && sudo apt-get install libttspico-utils and post the output too.


#30

No need for outpit, it works !

Snips-tts is installed and running !

Do you know why I must do this extra command ?


#31

Did you ever achieve your goal? I have a few AIY kits that are running on DietPi. I am considering a switch to Snips. I also have a VM server. It would be handy to run the bulk of the platform on a VM, leaving the Pi only needing to do the audio-related work.