Installing snips on Raspberry Pi


#1

I am trying to install snips on raspberry pi from windows machine. I have installed all the dependencies on the windows machine. I can able to connect to Pi using “Sam connect <>” but after running the command sam init, I get the following error

C:\Users\localuser>sam init
Installing Snips Platform components. This may take a few minutes…
V Updating aptitude repository
V Installing dirmngr
V Adding Snips APT source list
Adding Snips PGP public key
× Failed to install platform: Error: ENOENT: no such file or directory, open ‘C:
\Users\localuser\AppData\Roaming\npm\node_modules\snips-sam\lib\assets\snips-pgp
-key.asc’
at Object.openSync (fs.js:439:3)
at Object.readFileSync (fs.js:344:35)
at Function.readFile (C:\Users\localuser\AppData\Roaming\npm\node_modules\sn
ips-sam\lib\assets\assets.js:25:24)
at Function.pgpKey (C:\Users\localuser\AppData\Roaming\npm\node_modules\snip
s-sam\lib\assets\assets.js:19:21)
at sshCommandLog.then.then.then._ (C:\Users\localuser\AppData\Roaming\npm\no
de_modules\snips-sam\lib\session\ssh.js:457:64)
at process._tickCallback (internal/process/next_tick.js:68:7)


#2

Check you NodeJS version and npm.


#3

Thank you.
I could only able to install Snips by following the manual steps.


#4

Get same ERROR with
Win10,
Node.js 10.15.1 LTS


#5

Follow the manual steps to install snips. It worked for me