Intent is not created when using Satellite

I have been using snips as a solution for STT and passing intents to openHAB via MQTT with Mosquitto. This works well for my base server (kitchen). I am trying to extend this to a satellite snips setup (lounge) using a Raspberry Pi Zero W running Raspbian Stretch and a connected Sony Playstation 3 EyeToy (same as the microphone on my base server which is a Pi 3). I have Snips setup with snips-audio-server running on the satellite and using snips-watch I can see that the satellite is sending the hot-word and this is recognized by the base server. However the Dialog session is stopped on the satellite. Any help greatly received!

Cheers

vbevan

[Dialogue] session with id ‘f93bed7b-5f2f-4dd1-a887-86d6c376b6b0’ was ended on site kitchen. The session was ended because one of the component didn’t respond in a timely manner.

Here’s a result of using both kitchen and lounge (satellite) snips instances:

[14:06:12] Watching on localhost:1883 (MQTT)
[14:06:20] [Hotword] detected on site kitchen, for model hey_snips
[14:06:20] [Asr] was asked to stop listening on site kitchen
[14:06:20] [Hotword] was asked to toggle itself 'off' on site kitchen
[14:06:20] [Dialogue] session with id 'a8b9c467-ce91-46c1-b512-e9b2d726f3cc' was started on site kitchen
[14:06:20] [AudioServer] was asked to play a wav of 41.1 kB with id '80e60545-bec4-40df-82cf-8f57d5611ea5' on site kitchen
[14:06:21] [AudioServer] finished playing wav with id '80e60545-bec4-40df-82cf-8f57d5611ea5'
[14:06:21] [Asr] was asked to listen on site kitchen
[14:06:25] [Asr] captured text "turn the kitchen cupboard light on" in 3.0s
[14:06:25] [Asr] was asked to stop listening on site kitchen
[14:06:25] [AudioServer] was asked to play a wav of 93.1 kB with id 'c7b7db88-a238-403a-b0b3-386867531c7f' on site kitchen
[14:06:26] [AudioServer] finished playing wav with id 'c7b7db88-a238-403a-b0b3-386867531c7f'
[14:06:26] [Nlu] was asked to parse input "turn the kitchen cupboard light on"
[14:06:26] [Nlu] detected intent vbevan:turnOn with confidence score 0.908 for input "turn the kitchen cupboard light on"
              Slots ->
                     room_name -> kitchen (confidence: 1.000)
                 room_location -> unit (confidence: 1.000)
                     item_type -> light (confidence: 0.904)
[14:06:26] [Dialogue] New intent detected vbevan:turnOn with confidence 0.908
              Slots ->
                     room_name -> kitchen (confidence: 1.000)
                 room_location -> unit (confidence: 1.000)
                     item_type -> light (confidence: 0.904)
[14:06:31] [Dialogue] session with id 'a8b9c467-ce91-46c1-b512-e9b2d726f3cc' was ended on site kitchen. The session was ended because one of the component didn't respond in a timely manner
[14:06:31] [Asr] was asked to stop listening on site kitchen
[14:06:31] [Hotword] was asked to toggle itself 'on' on site kitchen
[14:06:39] [Hotword] detected on site lounge, for model hey_snips
[14:06:39] [Asr] was asked to stop listening on site lounge
[14:06:39] [Hotword] was asked to toggle itself 'off' on site lounge
[14:06:39] [Dialogue] session with id '9be9e49a-80e8-4c2e-a2b4-49f04da8cbde' was started on site lounge
[14:06:39] [AudioServer] was asked to play a wav of 41.1 kB with id '9c22da12-3f13-4441-97db-1c52917d9ace' on site lounge
[14:06:54] [Dialogue] session with id '9be9e49a-80e8-4c2e-a2b4-49f04da8cbde' was ended on site lounge. The session was ended because one of the component didn't respond in a timely manner
[14:06:54] [Asr] was asked to stop listening on site lounge

My Snips Audio Server setup on the kitchen base server:

 
[snips-common]
# bus = "mqtt"
# mqtt = "localhost:1883"
# audio = ["+@mqtt"]
# assistant = "/usr/share/snips/assistant"
# user_dir = "/var/lib/snips"

## MQTT authentication
#mqtt_username = ""
#mqtt_password = ""

## MQTT TLS configuration
# mqtt_tls_hostname = ""
# mqtt_tls_disable_root_store = false
# mqtt_tls_cafile = ""
# mqtt_tls_capath = ""
# mqtt_tls_client_cert = ""
# mqtt_tls_client_key = ""

[snips-analytics]

[snips-asr]
# no_fst_map = true
# beam_size = 8
# model = "/usr/share/snips/asr"
# audio = ["+@mqtt"]
# partial = false
# partial_period_ms = 250

[snips-asr-google]
# credentials = "/usr/share/snips/googlecredentials.json"
# audio = ["+@mqtt"]

[snips-audio-server]
# frame = 256
bind = "kitchen@mqtt"
# mike = "Built-in Microphone"
# disable_playback = false
# disable_capture = false

[snips-dialogue]
# resources = "/usr/share/snips/dialogue"
# session_timeout = 15
# lambda_timeout = 5
# retry_count = 3
# sound_feedback_disabled_default = false

[snips-hotword]
# model = "/usr/share/snips/hotword"
# hotword_id = "default"
# sensitivity = "0.5"
audio = ["kitchen@mqtt", "lounge@mqtt"]
# no_vad_inhibitor = false
# vad_messages = false

[snips-injection]
#asr_model = "/usr/share/snips/asr"
#nlu_engine = "/usr/share/snips/nlu_engine"
#keep_nfirst = 3

[snips-nlu]

[snips-tts]
## Choose one tts provider (defaults to picotts)
# provider = "picotts"
# provider = "makerstts"
# provider = "customtts"
## customtts specific configuration (here configured to use picotts using the en-US language)
## available placeholder variables : %%OUTPUT_FILE%%, %%LANG%%, %%TEXT%%
# customtts = { command = ["pico2wave", "-w", "%%OUTPUT_FILE%%", "-l", "en-US", "%%TEXT%%"] }`Preformatted text`
    indent preformatted text by 4 spaces
OS version ................... Raspbian GNU/Linux 9 (stretch)
Installed assistant .......... Anna
Language ..................... en
Hotword ...................... hey_snips
ASR engine ................... snips
Status ....................... Live

Service status:

snips-analytics .............. 0.63.2 (not running)
snips-asr .................... 0.63.2 (running)
snips-audio-server ........... 0.63.2 (running)
snips-dialogue ............... 0.63.2 (running)
snips-hotword ................ 0.63.2 (running)
snips-nlu .................... 0.63.2 (running)
snips-skill-server ........... 0.63.2 (running)
snips-tts .................... 0.63.2 (running)

My snips settings on the satellite (lounge):

[snips-common]
# bus = "mqtt"
mqtt = "192.168.178.71:1883"
# audio = ["+@mqtt"]
# assistant = "/usr/share/snips/assistant"
# user_dir = "/var/lib/snips"

## MQTT authentication
# mqtt_username = ""
# mqtt_password = ""

## MQTT TLS configuration
# mqtt_tls_hostname = ""
# mqtt_tls_disable_root_store = false
# mqtt_tls_cafile = ""
# mqtt_tls_capath = ""
# mqtt_tls_client_cert = ""
# mqtt_tls_client_key = ""

[snips-analytics]

[snips-asr]
# no_fst_map = true
# beam_size = 8
# model = "/usr/share/snips/asr"
# audio = ["+@mqtt"]
# partial = false
# partial_period_ms = 250

[snips-asr-google]
# credentials = "/usr/share/snips/googlecredentials.json"
# audio = ["+@mqtt"]

[snips-audio-server]
# frame = 256
bind = "lounge@mqtt"
# mike = "Built-in Microphone"
# disable_playback = false
# disable_capture = false

[snips-dialogue]
# resources = "/usr/share/snips/dialogue"
# session_timeout = 15
# lambda_timeout = 5
# retry_count = 3
# sound_feedback_disabled_default = false

[snips-hotword]
# model = "/usr/share/snips/hotword"
# hotword_id = "default"
# sensitivity = "0.5"
# audio = ["+@mqtt"]
# no_vad_inhibitor = false
# vad_messages = false

[snips-injection]
#asr_model = "/usr/share/snips/asr"
#nlu_engine = "/usr/share/snips/nlu_engine"
#keep_nfirst = 3`Preformatted text`

    OS version ................... Raspbian GNU/Linux 9 (stretch)
Installed assistant .......... Anna
Language ..................... en
Hotword ...................... hey_snips
ASR engine ................... snips
Status ....................... Live

Service status:

snips-analytics .............. (not running)
snips-asr .................... (not running)
snips-audio-server ........... 0.63.2 (running)
snips-dialogue ............... (not running)
snips-hotword ................ (not running)
snips-nlu .................... (not running)
snips-skill-server ........... (not running)
snips-tts .................... (not running)