Intent slots with multiple words


#1

Hi,
I am trying to create an intent to change the input of my soundbar (in German). I tried the intent creation in the console and generally everything works, just intent slots that contain a dash or a space do not seem to be recognized. I gave the training example “Spiele Musik auf der Soundbar vom [optischen Anschluss]” with [optischen Anschluss] being a possible value for the intent slot “input”. If I test the exactly same phrase on the right, the intent is recognized, but the slot is just an empty list.
The response from the test is:
{
“input”: “spiele musik auf der soundbar vom optischen anschluss”,
“intent”: {
“intentName”: “MalawiAli:change_input”,
“probability”: 0.91817456
},
“slots”: []
}

My slot definition contains the following synonyms for the optical input: “Optisches Kabel, Optischer Anschluss, Optischer Eingang, optischen Anschluss, optischen Eingang”. I added the inflected forms of “optischer” as a test, but it does not help. How can I make Snips recognize those values? The same problem occurs with “AUX-Eingang”.
Kind regards


#2

I think it works now. Do I have to save before it works? When I edit something it says that it is retraining the assistant, but I had to save and go back to the assistant main screen, then it worked. Sorry for opening this topic for nothing.