Keine Antwort von Snips - didn't respond

Hi,

hier mein Log aus sam watch:

[22:00:38] Watching on localhost:1883 (MQTT)

[22:00:54] [Hotword] detected on site default , for model hey_snips

[22:00:54] [Asr] was asked to stop listening on site default

[22:00:54] [Hotword] was asked to toggle itself ‘off’ on site default

[22:00:54] [Dialogue] session with id ‘b7c50447-fe40-4ae2-9543-3f5bb5498c40’ was started on site default

[22:00:54] [AudioServer] was asked to play a wav of 41.1 kB with id ‘59b1f7de-05a1-4ea9-85d4-9eccdfd33a50’ on site default

[22:01:10] [Dialogue] session with id ‘b7c50447-fe40-4ae2-9543-3f5bb5498c40’ was ended on site default . The session was ended because one of the component didn’t respond in a timely manner

[22:01:10] [Asr] was asked to stop listening on site default

[22:01:10] [Hotword] was asked to toggle itself ‘on’ on site default

Lautsprecher und Mikrofon Tests sind laut SAM ok. Assistent hat Unveränderte Apps aus dem Store. Keine Ahnung was los ist. Raspi 3B+ mit ReSpeaker 4Mic Pi-Hat. Ich bekomme keinen einzigen Ton ausgegeben. Vielleicht wisst ihr noch etwas, was ich noch nicht ausprobiert habe.

dein Lautsprecher ist per 3.5mm Klinke angeschlossen?
sam status sieht auch gut aus?
was gibt denn sam service log aus?
wie sieht deine /etc/asound aus?

gruss ryan

Hi,
ja Lautprecher ist per 3.5mm Klinke angeschlossen.

sam status

OS version … Raspbian GNU/Linux 9 (stretch)
Installed assistant … Snips
Language … de
Hotword … hey_snips
ASR engine … snips
Status … Live

Service status:

snips-analytics … (not running)
snips-asr … 0.63.2 (running)
snips-audio-server … 0.63.2 (running)
snips-dialogue … 0.63.2 (running)
snips-hotword … 0.63.2 (running)
snips-nlu … 0.63.2 (running)
snips-skill-server … 0.63.2 (running)
snips-tts … 0.63.2 (running)

EIne datei /etc/asound gibt es bei mir nicht.

Beim Deploy des Assistenten habe ich folgenden Log:
Fetching assistants done
Found 1 assistant named Snips
Downloading assistant
Fetching assistants done
:heavy_check_mark: Deploying assistant to snips.local…
Checking for actions
Python skill CrystalMethod.HelloWorld has 1 snippet:
CrystalMethod

Cloning skill domi.Wetter from url: https://github.com/MrJohnZoidberg/Snips-Wetter
Bereits aktuell.

Generating actions based on the snippets, copying the actions in /var/lib/snips/skills

INFO:snips_actions_templates_engine_lib: parsing snippets for app “/usr/share/snips/assistant/snippets/domi.Wetter”
INFO:snips_actions_templates_engine_lib: parsing snippets for app “/usr/share/snips/assistant/snippets/CrystalMethod.HelloWorld”
INFO:snips_actions_templates_engine_lib: parsing snippets dir “/usr/share/snips/assistant/snippets/CrystalMethod.HelloWorld/python2”
INFO:snips_actions_templates_engine_lib: parsed 1 snippets

Setting up Python actions
Running setup.sh & generating virtual environment for ansch190.HelloWorld

:heavy_multiplication_x: Error setting up virtualenv, one or more actions might not be able to run. Reason :

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7.

Running setup.sh & generating virtual environment for ansch190.Rechner

setup.sh output:

Looking in indexes: …

Requirement already satisfied: hermes-python>=0.2 in ./venv/lib/python3.5/site-packages (from -r requirements.txt (line 2)) (0.7.0)
Requirement already satisfied: enum34 in ./venv/lib/python3.5/site-packages (from hermes-python>=0.2->-r requirements.txt (line 2)) (1.1.6)
Requirement already satisfied: future in ./venv/lib/python3.5/site-packages (from hermes-python>=0.2->-r requirements.txt (line 2)) (0.17.1)
Requirement already satisfied: typing in ./venv/lib/python3.5/site-packages (from hermes-python>=0.2->-r requirements.txt (line 2)) (3.7.4)

Requirement already satisfied: six in ./venv/lib/python3.5/site-packages (from hermes-python>=0.2->-r requirements.txt (line 2)) (1.12.0)

Running setup.sh & generating virtual environment for CrystalMethod.HelloWorld

:heavy_multiplication_x: Error setting up virtualenv, one or more actions might not be able to run. Reason :

DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7.

Running setup.sh & generating virtual environment for Snips-Wetter

:heavy_multiplication_x: Error setting up virtualenv, one or more actions might not be able to run. Reason :

setup.sh: 30: .: Can’t open venv/bin/activate

Checking actions for end-user parameters
i Action Snips-Wetter contains secret parameters that needs to be configured
? Please enter a value for the parameter [openweathermap_api_key] 1111111111
? Please enter a value for the parameter [default_city] Cologne

i You can change these values later by editing the file located at /var/lib/snips/skills/Snips-Wetter/config.ini

Relaunching snips-skill-server
:heavy_check_mark: Snips assistant is now running. Say hey_snips to start!
i Run sam watch to see the logs

Hier die Ausgabe von sam watch und dem Service log nach “Hey Snips”:

sam watch:

[14:29:28] Watching on localhost:1883 (MQTT)
[14:29:48] [Hotword] detected on site default , for model hey_snips
[14:29:48] [Asr] was asked to stop listening on site default
[14:29:48] [Hotword] was asked to toggle itself ‘off’ on site default
[14:29:48] [Dialogue] session with id ‘b6ee0aaa-fe0e-49f2-83ec-14aff569ad15’ was started on site default
[14:29:48] [AudioServer] was asked to play a wav of 41.1 kB with id ‘8f97ccc5-4cd8-4756-877c-ead3fbdab690’ on site default
[14:30:03] [Dialogue] session with id ‘b6ee0aaa-fe0e-49f2-83ec-14aff569ad15’ was ended on site default . The session was ended because one of the component didn’t respond in a timely manner
[14:30:03] [Asr] was asked to stop listening on site default
[14:30:03] [Hotword] was asked to toggle itself ‘on’ on site default

service log:

Jun 30 14:29:48 snips snips-hotword[2281]: INFO:snips_hotword_hermes : Hotword detected: site_id:default model:hey_snips (103ms ago)
Jun 30 14:29:48 snips snips-dialogue[2284]: INFO:snips_dialogue_lib::coordinator::coordinator: Site [default]: reset site -> turn off ASR and turn off Hotword
Jun 30 14:29:48 snips snips-dialogue[2284]: INFO:snips_dialogue_lib::coordinator::coordinator: Session [b6ee0aaa-fe0e-49f2-83ec-14aff569ad15]: The session has been created because the site “default” is free
Jun 30 14:29:48 snips snips-audio-server[2292]: INFO:snips_audio_portaudio : Playing “8f97ccc5-4cd8-4756-877c-ead3fbdab690” using output “bcm2835 ALSA: IEC958/HDMI (hw:0,1)”, wav spec: WavSpec { channels: 2, sample_rate: 22050, bits_per_sample: 16, sample_format: Int }
Jun 30 14:29:48 snips snips-audio-server[2292]: Expression ‘paInvalidSampleRate’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 2043
Jun 30 14:29:48 snips snips-audio-server[2292]: Expression ‘PaAlsaStreamComponent_InitialConfigure( &self->playback, outParams, self->primeBuffers, hwParamsPlayback, &realSr )’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 2717
Jun 30 14:29:48 snips snips-audio-server[2292]: Expression ‘PaAlsaStream_Configure( stream, inputParameters, outputParameters, sampleRate, framesPerBuffer, &inputLatency, &outputLatency, &hostBufferSizeMode )’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 2838
Jun 30 14:29:48 snips snips-audio-server[2292]: ERROR:snips_audio_server_hermes : could not play “8f97ccc5-4cd8-4756-877c-ead3fbdab690”
Jun 30 14:29:48 snips snips-audio-server[2292]: -> caused by: InvalidSampleRate
Jun 30 14:29:48 snips snips-audio-server[2292]: thread ‘portaudio.player’ panicked at ‘called Result::unwrap() on an Err value: “SendError(…)”’, src/libcore/result.rs:997:5
Jun 30 14:29:48 snips snips-audio-server[2292]: note: Run with RUST_BACKTRACE=1 environment variable to display a backtrace.
Jun 30 14:29:48 snips snips-hotword[2281]: INFO:snips_hotword_lib::audio : Audio thread for site default stopped.
Jun 30 14:30:03 snips snips-dialogue[2284]: INFO:snips_dialogue_lib::coordinator::coordinator: Session [b6ee0aaa-fe0e-49f2-83ec-14aff569ad15]: closing session which was active: Timeout
Jun 30 14:30:03 snips snips-dialogue[2284]: INFO:snips_dialogue_lib::coordinator::coordinator: Site [default]: reset site -> turn off ASR and turn on Hotword
Jun 30 14:30:03 snips snips-hotword[2281]: INFO:snips_hotword_lib::audio : Audio thread for site default started.

Ich hoffe dies hilft. Ich lese hier zwar Ausgabe des Tons über HDMi, aber ich habe über raspi-config auf Force 3.5 gestellt.

Hallo,

mein snips läuft schon seit Mai 2018 (mit Unterbrechungen durch neuinstallationen und Fehler in den Matrix Voice Kernelmodulen). Gefühlt seit Januar aber ist er immer stabil gelaufen. Als ich nun mal wieder ein Update gemacht habe wurde ein Kernelupdate vorgeschlagen welches ich gemacht habe (bin jetzt auf 4.19). Seither habe ich den selben Fehler wie du. Ich denke es liegt am snips audioserver im Zusammenspiel mit den neuen Kernel. sam test audio funktioniert.

Leider habe ich noch keine Antworten in einem der englischen Threads bekommen. Habe aber schon alles ausprobiert. Schade, hatte mich mittlerweile an snips gewöhnt. Einen Neuinstallation scheint ja auch nicht zu helfen.

Grüße, Jochen

Hi Jochen,

ein Problem mit Treiber/Kernel hatte ich auch schon im Blick, da die vorgegebene Ausgabe nach der Treiberinstallation von der ReSpeaker Website bei mir abweicht. Da die “sam test” jedoch funktionieren und auch Videos im Browser oder andere Medienwiedergaben funktionierten, dachte ich es ist alles in Ordnung. Hat Snips bei dir vorher trotz dieser “DEPRECATION: Python 2.7” Warnung bei dir funktioniert? Nicht, dass es auch dort ein Problem gibt.

Gruß ansch190

Hallo,

habe es dank dem genialen @Psycho wieder am laufen. Er hat seine asound.conf auf Discord gepostet die funktioniert:

pcm.!default {
  type asym
  capture.pcm "mic"
  playback.pcm "speaker"
}
pcm.mic {
  type plug
  slave.pcm "multiapps"
}
pcm.multiapps {
  type dsnoop
  slave {
    pcm "hw:Device"
    buffer_size 96000
  }
  ipc_key 666666
}
pcm.speaker {
  type plug
  slave {
    rate 16000
    pcm "hw:ALSA"
  }
1 Like

Hat für mich leider nicht funktioniert. Hab die asound.conf eins zu eins ausgetauscht.

Hallo,

sorry, dann weiß ich leider auch nicht.

Hoffentlich kommt von snips.ai bald ein update für den audio-server.

@joeduck sag mal fehlt bei deiner asound.conf nicht am Ende eine “}” der Block pcm.speaker ist nicht abgeschlossen.

Hast recht. Sorry.
Muss beim posten passiert sein

Hallo zusammen,

hab auch das Problem das ich keine Antwort / Reaktion bekomme obwohl laut Test alles funktioniert.
Gib es schon irgend eine Möglichkeit es zum laufen zu bekommen ? Die asound.conf habe ich auch schon versucht anzupassen, hat aber leider nicht geklappt.

grüsse

Hallo zusammen,

ich denke das folgende habt ihr bereits des öfteren nachgeprüft.
Da es mir aber vor kurzem passiert ist, schreibe ich es einfach noch mal auf.

Ich hatte nach einer längeren Snips Offline-Zeit das Gerät mal wieder eingeschaltet.
Aber irgendwie kam kein Ton mehr raus. Er hatte das ‘Wake-Word’ verstanden und auch das was ich wollte, aber akustisches Feedback kam nicht.
Irgendwie war die Lautstärke von der Box, die per 3,5mm Klinke am Pi angeschlossen ist, auf null.
Somit habe ich dann sudo alsamixer aufgerufen und die Lautstärke hochgedreht.

Eventuell hilft es ja dem einen oder anderen.

Gruss Ryan