NLU not running on Mac

Hi, I’m running Snips app on the mac. I tested this app couple weeks ago and it worked perfectly. However, when i run this app again today, the NLU part seems not working any more and as a result no intent is recognized. Below is my log and you can see after the ASR captures the text, nothing happens although NLU and intent recognition unit should be triggered ideally.

I’ve reinstall “snips-asr snips-hotword snips-dialogue snips-watch
snips-audio-server snips-nlu snips-tts” and tried to “brew services start” and stop many times. But it’s still not working right now. Any help? Do anyone know why this happens? Thanks so much guys.

C02SREKZGTFM:test yma15$ snips-watch -v
[11:04:53] Watching on localhost:1883 (MQTT)
[11:04:56] [Hotword] detected on site default, for model hey_snips
[11:04:56] [Dialogue] session with id ‘42f3a283-1776-4ccf-9543-e50e9e373a53’ was started on site default
[11:05:00] [Asr] captured text “give me a document” in 3.0s

did you rebuild your assistant in the console and deployed it??

@marriema

To check that run snips-nlu -v in your terminal, if its not you will see an explicit log about this problem.

yes I did that already

Thx but i don’t have snips-nlu command in mac. The only thing i have is snips-watch.

well that is a problem :slight_smile:

did you use the brew start service commands to start the Snips services???