No audio from the pygame mixer

#1

Hi everybody,
I have a problem with the assistant on Ubuntu 16.04. I’m using pygame.mixer to start a song requested with the assistant and it recognizes the song but there is no audio in output. I think there are two processes (snips and pygame.mixer) that are trying to use the output audio but only the assistant use the output. When the assistant is not using the output the music can start.
The same assistant was on a Raspberry PI, but there wasn’t any problem with it.

Thanks

#2

need to include snoop settings with your audio so that two programs can use the sound object at the same time

1 Like
#3

Hi,

I searched how to configure snoop in audio settings but I didn’t find anything. How can I include it in my audio?
I have hda intel pch as sound card. I tried to do “sudo alsa force-reload” and I saw that 2 processes that use pulseaudio get killed.

Thanks

EDIT:
I tried to add this line “options snd-hda-intel vid=8086 pid=8ca0 snoop=0” to /etc/modprobe.d/alsa-base.conf but I didn’t solve the problem.

EDIT2:
I found that snips-audio-server is taking exclusivity of the sound card and pygame is using the output dummy to stream the music. I stopped and started again the snips-audio-server to release the sound card but now the assistant can’t receive any voice input.

EDIT3:
I’ve found out that Snips is using pulse audio to get the exclusive permission of the sound card. To use Snips while Ubuntu can reproduce any sound, I have disabled the snips-audio-server service. After the reboot of the OS, I can hear the system’s sounds of Ubuntu. Then from the terminal, I have typed only snips-audio-server to start manually as an application and now I can reproduce any sounds while Snips is using the speaker as a normal program. Is that a normal behavior?