No Devices Discovered

#1

So I’m in the process of setting up Snips on a Ubuntu 18.04 VM and a satellite Pi Zero W.

I started this a while back but I just got around to getting the Pi Zero W. So today I decided I’d get the server up and running first, do some soldering to get the ReSpeaker 2 on the Zero and start listening to my kids ask Snips to do stuff it can’t.

So I’ve done a bunch of reading and I’ve gotten snips-platform-voice, snips-platform-demo, snips-tts (and deps), snips-template, snips-skill-server, snips-watch, nodejs, and snips-sam installed.

I ran sudo sam connect localhost cause well I’m ssh’d into the server. I used the default username and password but that didn’t work

So I then tried sudo sam devices and was told that there were ‘No devices discovered’

Help please

#2

Indeed, sam is not that good at discovering devices. You just have to discover them yourself and then connect with:

sam connect <HOSTNAME_OR_IPADDRESS>
1 Like
#3

Ah,

I tried sam connect localhost and sam connect 192.168.1.125, I tried the default username and password but I keep getting:

:heavy_multiplication_x: Error connecting to localhost: All configured authentication methods failed

Could I have changed this at some point during the install? Is there a spot where I can see the username and password?

I checked the status of Snips and this what I get:

snips-tts.service - Snips TTS
Active: active (running)

snips-dialogue.service - Snips Dialogue
Active: active (running)

snips-nlu.service - Snips NLU
Active: active (running)

snips-hotword.service - Snips Hotword
Active: active (running)

snips-skill-server.service - Snips Skill Server
Active: activating (auto-restart) (Result: exit-code)

I can’t seem to get snips-skill-server.service running, and I don’t know if this is what’s preventing me from connecting.

#4

Hi Hav0ck!

Did you try the credentials of the console login?

Bye
freddy

#5

Hi Freddy,

Thanks for the suggestion but that didn’t work either.

I haven’t really uncommented anything in my snips.toml file, could that be the issue?

#6

So I finally figured this out.
The Sam logon is asking for the SSH credentials for the computer.

1 Like