Personal wake word is not recognized


#21

Unfortunately not yet :frowning:

And yes, hotword service is running without displaying errors.


#22

I have the exact same problem, seems to be a Software side issue. All the services are running fine, I can record my personal hotword, play it back and adjust sensitivity etc.
But once I uncomment the model line in the snips.toml the word isn`t recognized and nothing works until I put the basic configuration and hotword configuration back to “Hey Snips”. Hopefully this gets addressed fast, since the basic “Hey Snips” hotword gets activated by accident all the time, like while having a conversation or watching TV. The system is pretty much unusable right now because it gets activated so many times, I actually had to shut it down for now… :frowning: Is it possible to at least alter the sensitivity of the Basic Hotword? Somewhere it says that it just defaults to 0.5 but is there a way to change that?


#23

Same problem for me , did you solved your ?


#24

Did you ever figure out how to get rid of the phantom “snips-record-personal-hotword.service”?

I’ve tried everything you did, plus “update-rc.d -f snips-record-personal-hotword remove”. I’ve also tried placing a dummy “snips-record-personal-hotword.service” file in /etc/systemd/system and then “sudo systemctl disable snips-record-personal-hotword.service” with no effect.

It’s annoying… stopping with wildcard works, but start or restart snips-* does nothing, it seems to block on the phantom, so I have to either use a shell script naming them individually, or reboot.

I trawled through umpteen Google searches trying to find out where it could be defined, to no avail.

[edit] I’ve also searched all other units to see if any are calling this one.


#25

I have the same problem. Logs look good, but no custom hotword detection. The config.json looks a little different, but I don’t know which of these fields are supposed to be the same or can be different. There is no w_max or w_smooth – is that the problem?

    "num_mel_bins": 13, 
    "window_type": "povey", 
    "kind": "personal", 
    "window_size": 10, 
    "cepstral_lifter": 22.0, 
    "use_energy": false, 
    "energy_floor": 0.0, 
    "from_mfcc": 1, 
    "dtw_ref": 0.22, 
    "raw_energy": true, 
    "frame_length_ms": 25.0, 
    "frame_shift_ms": 10.0, 
    "preemphasis_coefficient": 0.97, 
    "to_mfcc": 13, 
    "sample_rate": 16000, 
    "dither": 0.0, 
    "mel_low_freq": 20, 
    "shift": 10, 
    "num_mfcc": 13, 
    "band_radius": 10, 
    "hotword_key": "personalhotword"

#26

Hi,
You should use snips-* with double quotes or else your shell will try to expend it against files or directory in the current directory