Pip3 install from git error

Hey I’m new an try to create my first App. I want to use Spotipy but with “pip3 install spotipy” i get an outdatet version of it. I have to use “pip3 install git+https://github.com/plamere/spotipy.git”. I made an setup.sh with this in it:
#!/usr/bin/env bash -e

PYTHON=which python3
VENV=venv

if [ -f “$PYTHON” ]
then

if [ ! -d $VENV ]
then
    # Create a virtual environment if it doesn't exist.
    $PYTHON -m venv $VENV
else
    if [ -e $VENV/bin/python2 ]
    then
        # If a Python2 environment exists, delete it first
        # before creating a new Python 3 virtual environment.
        rm -r $VENV
        $PYTHON -m venv $VENV
    fi
fi

# Activate the virtual environment and install requirements.
. $VENV/bin/activate
pip3 install -r requirements.txt

else
>&2 echo “Cannot find Python 3. Please install it.”
fi

And an requirement.txt with this in it:

Bindings for the hermes protocol

hermes-python>=0.7
toml
git+https://github.com/plamere/spotipy.git

But when installing th assistant i get an Error:

:heavy_multiplication_x: Error setting up snips-music-actions, one or more actions might not be able to run. Reason :
Failed building wheel for spotipy

When I call:
“pip3 install -r requirements” in the action-directory of my app, the installation works fine.

What is wrong? Can anyone help me ??

PS: here is the link to the reposetory:

here is what my setup.sh files look like

#/usr/bin/env bash -e

VENV=venv

if [ ! -d "$VENV" ]
then

    PYTHON=`which python3`

    if [ ! -f $PYTHON ]
    then
        echo "could not find python"
    fi
    virtualenv -p $PYTHON $VENV

fi

. $VENV/bin/activate

pip install -r requirements.txt