Platform update 1.0.1 (0.60.8) - 18/12/2018

platform-release

#1

Platform Update 1.0.1 (0.60.8) - 18/12/2018

Note A bug was discovered after the release preventing users from deactivating the heartbeat. This has been fixed, do not install the version 0.60.8 version to prevent it.

The heartbeat does not contain any data, and is only sent by a device to say it is alive. The IP is erased at the infrastructure level, guaranteeing no sensitive information can be derived from the heartbeat

Manual procedure to patch the bug --> https://docs.snips.ai/guides/advanced-configuration/heartbeat-configuration

  • New features

    • Voice Activity Detector: Wake Word Detector is inhibited when no voice activity is detected to limit CPU usage.
  • Improvements

    • Delay-less WakeWord-to-ASR: When audio feedback is disabled, it is not needed anymore to emphasize the pause between the wake word and the request.

    • Snips audio server: Alsa playback robustness is improved.

    • Improved path detection and error messages for assistant installed by the user.

  • Bug fixes

    • snips-skill-server: Fix a crash when a skill writes a file in /tmp.

    • snips-injection: Fix a crash when injecting entity values on android.

    • snips-asr: Fix multiple performance issues related to ASR partial decoding. The CPU footprint of this feature can be significant, depending on the size of the assistance, and the frequency of partial decodings.

    • snips-dialogue: It is now possible to update the customData field in the continueSession message payload.

  • Documentation

    • Hermes messages:

      • Audio timestamps (doc)

      • Enable/Disable the sound feedback (doc)

      • Continue session message (doc)

    • Add Partial ASR (doc)

    • Add VAD documentation (doc)

  • Incompatibility / possible breaking change

    • The delay-less WakeWord-to-ASR benefits from new features of snips-audio-server . If you are not using snips-audio-server but a custom re-implementation, we recommend disabling them by passing the option -–no_snips_audio_server_replay when running snips-asr.
  • Known issues

    • Jackd audio support is not supported in this build for raspbian and docker arm.

#2

:slight_smile: nice changes… whats next ?? :slight_smile:

i find the pause is still required… with no pause the sequence never starts. its like the hotword is not heard correctly

I do still find the toml setting sound_feedback_enabled_default counter intuitive for its value
sound feedback enabled = true (sound is off)
sound feedback enabled = false (sound is on)

enabled true would seem on, and enabled false would seem off… but its backwards


#3

Thanks for your feedbacks!

sound_feedback_enabled_default is a deprecated option, you should rather use sound_feedback_disabled_default.

Thanks for pointing it out, the documentation has been updated accordingly.

Regarding the pause after the WakeWord, is it still required but strongly shorten.
Indeed, when the pause is inexistent the wake word will not be detected.

Still, we hope it will improve your experience :slight_smile:


#4

also…

there is no options for snips-asr to pass in no_snips_audio_server_replay

i ran snips-asr --help and it does not list it

wanted to try with the replay disabled to see if the ASR partial would speed up at all


#5

@ozie could you do a dpkg -l | grep snips and paste here the output so that we can know the exact versions of the binaries you have installed ?
Thanks !


#6
ii  libatlas3-base                  3.10.3-1-snips                    armhf        Automatically Tuned Linear Algebra Software, generic shared
ii  snips-analytics                 0.60.8                            armhf        Snips Analytics
ii  snips-asr                       0.60.8                            armhf        Snips Automatic Speech Recognition
rc  snips-asr-injection             0.58.3                            armhf        A CLI tool to manage words injection into Snips ASR models
ii  snips-audio-server              0.60.8                            armhf        Snips Audio Server command line interface
ii  snips-dialogue                  0.60.8                            armhf        Snips Dialogue Manager command line interface
ii  snips-hotword                   0.60.8                            armhf        Snips Hotword command line interface
ii  snips-kaldi-atlas               0.23.3                            armhf        Snips/Kaldi C/C++ wrapper
ii  snips-makers-tts                0.60.8                            armhf        TTS engine and voice based on Mycroft's Mimic
ii  snips-nlu                       0.60.8                            armhf        Snips Natural Language Understanding command line interface
ii  snips-platform-common           0.60.8                            armhf        Base package for configuration
ii  snips-platform-voice            0.60.8                            armhf        Metapackage for snips-platform voice assistant
ii  snips-skill-server              0.60.8                            armhf        Snips skill server command line interface
ii  snips-template                  0.60.8                            armhf        A CLI tool to work with templates for Snips actions
ii  snips-tts                       0.60.8                            armhf        Snips TTS
ii  snips-watch                     0.60.8                            armhf        CLI tool to monitor what the snips platform is doing


#7

@ozie hum. Just installed the latest version on a Pi and i can’t reproduce :

pi@pi-garvys:~ $ snips-asr --version
snips-asr 0.60.8
pi@pi-garvys:~ $ snips-asr --help
snips-asr 0.60.8
Snips <contact@snips.ai>
Snips Automatic Speech Recognition

USAGE:
    snips-asr [FLAGS] [OPTIONS] [SUBCOMMAND]

FLAGS:
        --color
            Force logs to display in color

    -h, --help
            Prints help information

        --mqtt-tls-disable-root-store
            Disable built-in Certificate bundle store

        --no_snips_audio_server_replay
            Disable replay protocol (compatibility with third party audio-server)

#8

@Garvys i found the problem. I copied the command from the top update post and pasted into terminal. Seems the “–” is not the right “–”

snips-asr -–no_snips_audio_server_replay
error: Found argument '-–' which wasn't expected, or isn't valid in this context

manually typing – works… as for the not found in --help, seems I am just blind :face_with_monocle:


#9

what system is SNIPS using to test these days? still testing under a RPi3B+ ??
(I would be running snips on a mac if only the brew was built for duo core - can’t run snips 24/7 on my i7 laptop)


#10

ok ! :smile:
Yes Pi 3 is our main test board


#11

Is this version safe for the Pi0? The release notes for 1.0.0 said not to install on a Pi0, but I didn’t ever see a mention of a fix.


#12

@platup basically in a satellite configuration, if you’re running the wakeword on the RPI3 you’re fine. Do not try to run the wakeword on the the PI0 it will perform badly. We are working on a fix.


#13

Wonderful update, thank you! I can clearly see a decrease in CPU usage. I take the opportunity to thank you for the amazing work, Snips works just fantastic on my Rasp 3B+ and a Mic Array 2.0! As a developer myself, it takes quite a bit to surprise me, but I am genuinely impressed by the quality of the software and how you manged to put a very responsive speech recognition engine on such a tiny platform.
I use it together with Jeedom and it works like a charm.
Keep up the good work!
Happy Holidays


#14

@flymac thanks so much for this message! Shared it with the team, felt like Christmas before Christmas! :heart:


#15

Since the update my Rasp 3B and Mic Array 2.0, I have more sound! I tried lots of things but never sound. the microphone test works, but the speaker test gives nothing.
I did sudo sam audio setup, did the reinstallation of Mic Array 2.0,
Otherwise everything works perfectly with sam watch we read the answers but no sound.
With sudo sam init I have the answer
Installing Snips Platform components. This may take a few minutes …
:heavy_multiplication_x: Error: No credentials found
I reinstalled the wizard and Mic Array 2.0.
I do not know what to do

Happy Holidays


#16

Looks like you have to do a sam login again


#17

As soon as I’m back home I do it again, but it seems to me that I had already tried so … I would try again but since I downgraded my version of Snips


#18

Delay-less WakeWord-to-ASR works as expected! Thanks for update.