Python/pip Error in update-assistant


#1

Hi,

I am getting two Python errors while trying to update my assistant:

Error setting up virtualenv, one or more actions might not be able to run. Reason :
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Error setting up virtualenv, one or more actions might not be able to run. Reason :
You are using pip version 18.1, however version 19.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command

I have upgraded pip to 19.0.1, but it has something to do with the venv, doesn’t it? Any pointers would be helpful!

Lukas


Snips python 3 instead of python 2
Error setting up virtualenv - what to do?
#2

You have to change the source to go to the venv (virtual environnement) and do the upgrade.


#3

For every skill? Because the folder /var/lib/snips/skills/snips-skill-heure/ doesn’t exist on my system. Or is that the problem? I may have deleted the contents of the skills folder recently to remove a deprecated skill.


#4

No, just for the skill in error.


#5

Which is all of them :slight_smile:


#6

Okay, this fixes the pip errors, not however the Python 2.7 error. If I fix the pip error for any app, the Python error shows up. What’s up with that?


#7

Python 2.7 will become deprecated. All Snips skills should migrate to Python 3.


#8

Actually I’m facing the same error.

Note: A Deprecation WARNING is not something, which should prohibit the correct installation.

Is this a virtualenv error or an error, which originates from snips?