Python-vlc permission denied when action is run

#1

Hello all,

I’m trying to create an app that will play an mp3 file when the action is run using python-vlc bindings. The error I am receiving is filesystem stream error: cannot open file /home/pi/Loser.mp3 (Permission denied). If I start a venv in the app directory and run the python file in the venv manually, it works. The folder holding the mp3 file is set with permissions 777. Any thoughts?

#2

Hello mike_dh_mount,

You might want to check the permissions on /home/pi directory. The skills server is not running under the pi user and therefore might not have access to the home dir of the pi user.

#3

Thanks for the reply.

I permissions were set to 755 on /home/pi, but as a test I changed them to 777 momentarily. Still no luck, same error message.

#4

I’ve found that if I put the file in the same directory as the skill, that I am able to get it to play. Any thoughts on what permissions are needed to get it playing from the /home/pi directory? I would have thought that making /home/pi 777 or even 775 would be enough.