Respeaker 2 mic issue new install (28/12/18) with 2018-11-13-raspbian-stretch-liteinstall

respeaker

#1

I am new to Raspberry, Snips, and unexperienced in Linux, but with some manuals I do get along…
I did scan the forum for similar issues, but didn’t find the right hit.

I received a SNIPS kit, but I think it is not recognizing my add-on card with ReSpeaker 2-Mics Pi HAT, because installs fort his card are failing,

I am working with Ubuntu from my Windows10 laptop and through SSH with the PI.

pi@raspberrypi:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 7/7
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

I’ll try to manually install the microphone files.

Running script as mentioned on: http://wiki.seeedstudio.com/ReSpeaker_2_Mics_Pi_HAT/

With SSH connection tot he PI.

1 file (snips.listsudo is ignored because of invalid filename extension, I presume it is okay…?

Creating symlink /var/lib/dkms/seeed-voicecard/0.3/source ->
/usr/src/seeed-voicecard-0.3

DKMS: add completed.

Kernel preparation unnecessary for this kernel. Skipping…

Building module:
cleaning build area…
make -j4 KERNELRELEASE=4.14.79+ -C /lib/modules/4.14.79+/build M=/var/lib/dkms/s eeed-voicecard/0.3/build…(bad exit status: 2)
Error! Bad return status for module build on kernel: 4.14.79+ (armv7l)
Consult /var/lib/dkms/seeed-voicecard/0.3/build/make.log for more information.

Kernel preparation unnecessary for this kernel. Skipping…

Building module:
cleaning build area…
make -j4 KERNELRELEASE=4.14.79-v7+ -C /lib/modules/4.14.79-v7+/build M=/var/lib/ dkms/seeed-voicecard/0.3/build…(bad exit status: 2)
Error! Bad return status for module build on kernel: 4.14.79-v7+ (armv7l)
Consult /var/lib/dkms/seeed-voicecard/0.3/build/make.log for more information.
mkdir: cannot create directory ‘/etc/voicecard’: File exists
git init
Reinitialized existing Git repository in /etc/voicecard/.git/
git add --all
git commit -m “origin configures”
On branch master
nothing to commit, working tree clean

Please reboot your raspberry pi to apply all settings

*** Browsing the logfile:

pi@raspberrypi:~/seeed-voicecard $ cat /var/lib/dkms/seeed-voicecard/0.3/build/make.log

DKMS make.log for seeed-voicecard-0.3 for kernel 4.14.79-v7+ (armv7l)

Mon 31 Dec 15:16:35 GMT 2018

make: Entering directory ‘/usr/src/linux-headers-4.14.79-v7+’

AR /var/lib/dkms/seeed-voicecard/0.3/build/built-in.o

CC [M] /var/lib/dkms/seeed-voicecard/0.3/build/wm8960.o

CC [M] /var/lib/dkms/seeed-voicecard/0.3/build/ac108.o

CC [M] /var/lib/dkms/seeed-voicecard/0.3/build/ac101.o

CC [M] /var/lib/dkms/seeed-voicecard/0.3/build/seeed-voicecard.o

LD [M] /var/lib/dkms/seeed-voicecard/0.3/build/snd-soc-wm8960.o

ld:built in linker script:6: ignoring invalid character `"’ in expression

ld:built in linker script:6: ignoring invalid character `"’ in expression

ld:built in linker script:7: ignoring invalid character `"’ in expression

ld:built in linker script:8: syntax error

scripts/Makefile.build:574: recipe for target ‘/var/lib/dkms/seeed-voicecard/0.3/build/snd-soc-wm8960.o’ failed

make[1]: *** [/var/lib/dkms/seeed-voicecard/0.3/build/snd-soc-wm8960.o] Error 1

make[1]: *** Waiting for unfinished jobs…

ld:/var/lib/dkms/seeed-voicecard/0.3/build/.tmp_seeed-voicecard.ver:1: syntax error

scripts/Makefile.build:328: recipe for target ‘/var/lib/dkms/seeed-voicecard/0.3/build/seeed-voicecard.o’ failed

make[1]: *** [/var/lib/dkms/seeed-voicecard/0.3/build/seeed-voicecard.o] Error 1

Makefile:1527: recipe for target ‘module/var/lib/dkms/seeed-voicecard/0.3/build’ failed

make: *** [module/var/lib/dkms/seeed-voicecard/0.3/build] Error 2

make: Leaving directory ‘/usr/src/linux-headers-4.14.79-v7+’

*** I have no idea how to solve this ! any help is appreciated


#2

Can you state exactly your steps after the unboxing?
Assembling the kit I assume, and then?


#3

Please use triple quote for posting logs or code.

SSH to your pi, and do the following:

sudo apt-get update
sudo apt-get dist-upgrade

And try to reinstall your respeaker

cd ~
sudo rm -rf seeed-voicecard
git clone https://github.com/respeaker/seeed-voicecard.git
cd seeed-voicecard
sudo ./install.sh
reboot

#4

Shouldn’t “sam init” ask you if you have a makerkit and if so, solve this problem?


#5

I assume the Respeaker 2 Mics Pi Hat is a capture device not a playback device so you should use arecord -l to check whether it is found.
If you want to check whether it works without snips or anything extra you can use arecord -vv -f dat /dev/null.
If it’s not the default capture device you’ll have to add “-Dhw:x,y” with x being the card number and y the device number (usually 0).
This should show you some info and a horizontal bar that displays the input volume so saying something should result in the bar moving to the right.
If you get device or resource busy, snips is probably using it already.
Then I’d try using sam test speaker to confirm the speakers work, followed by sam test microphone.


#6

Hi, thanks for your reply!
After assembly (put microphone card on top of the PI and plug in the speaker I follow these steps: https://docs.snips.ai/getting-started/quick-start-raspberry-pi
in Step 4: Configure the hardware I don’t hear anything from mic or speaker.
during running sam setup audio I see some errors in expression:
‘’’
guus@Latitude-E7440:~$ sam setup audio
? Is it a Snips Makers Kit? Yes
:heavy_check_mark: Installing ReSpeaker 2 mic hat
:heavy_multiplication_x: /usr/bin/ld:built in linker script:6: ignoring invalid character "' in expression /usr/bin/ld:built in linker script:6: ignoring invalid character“’ in expression
/usr/bin/ld:built in linker script:7: ignoring invalid character `”’ in expression
/usr/bin/ld:built in linker script:8: syntax error
collect2: error: ld returned 1 exit status
make: *** [action-app_respeaker] Error 1
Rebooting device. . . done
:heavy_check_mark: Device has rebooted
:heavy_multiplication_x: Error fetching audio capture device: No capture devices found. Check if your mic is correctly plugged.
i If the microphone is not connected through USB, you might need to install it yourself. See the manufacturers installation guide
i Using default capture configuration card 1 subdevice 0
? Found 2 interfaces to output sound.
Choose the one you want to use as your speaker (Use arrow keys)
❯ card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]

Choose the one you want to use as your speaker card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
:heavy_check_mark: Installed /etc/asound.conf
Setting to volume to 90% if possible
Restarting snips-audio-server service done
i You can test your microphone & speaker with sam test microphone / speaker
guus@Latitude-E7440:~$ sam test speaker
‘’’


#7

Hi thanks for your reply, I stil lgot stuck during microphone/speaker install, your hint is ginving the same error as I had earlier. : errors in expressions


#8

it does ask the question, and I answer with Yes, but still the install is failing


#9

Hi , I have tried your suggestion but I don’t seems to get the right info:
‘’’
pi@raspberrypi:~ arecord -l **** List of CAPTURE Hardware Devices **** pi@raspberrypi:~ arecord -vv -f dat /dev/null
ALSA lib pcm_hw.c:1713:(_snd_pcm_hw_open) Invalid value for card
arecord: main:788: audio open error: No such file or directory
pi@raspberrypi:~ ^C pi@raspberrypi:~ arecord -vv -f dat /dev/null -Dhw:0,0
arecord: main:788: audio open error: No such file or directory
pi@raspberrypi:~ $
‘’’


#10

It can’t find any capture device. arecord -l lists your capture devices and as you can see it doesn’t have any.
That’s probably your problem. Now, the question is why it can’t find it.
I assume the mic is connect using USB? (I don’t have the maker kit, just using a pi and Respeaker MicArray v2)
If so you can check if the device itself is recognized by unplugging the mic, running lsusb, then plugging it in and running lsusb again. The difference should be the device. If there is no difference, the device was not recognized and I’d advise you to try a different cable. I had to try like 4 usb to micro usb cables that I had lying around until I found one that didn’t just provide power.