Run and Deploy on Ubuntu local device

#1

How to deploy and run model on laptop running on ubuntu. I have no raspberrypi. I need guidance. Thanks

Run Snips on Ubuntu 16 Xenial on Pi3
Does Snips actually work on Ubuntu?
#2

hello sibt,

If you have ubuntu 16 or higher with a x86_64 cpu (intel, amd) … then you can install the platform like this

sudo apt-get update
sudo apt-get install -y dirmngr
sudo bash -c  'echo "deb https://debian.snips.ai/stretch stable main" > /etc/apt/sources.list.d/snips.list'
sudo apt-key adv --keyserver pgp.mit.edu --recv-keys F727C778CCB0A455

sudo apt-get update
sudo apt-get install -y snips-platform-voice
sudo apt-get install -y snips-platform-demo
sudo apt-get install -y snips-tts snips-template snips-skill-server
sudo apt-get install -y snips-watch

the rest of the documentation applies … the only difference is the install url found in the above command

you then need to configure the sound and test the platform , if you are using pulseaudio you will need :

sudo usermod -a -G pulse-access _snips

this will also work for other linux …

1 Like
#3

Hello,

It looks like this howto is not valid anymore.
I got an error while update apt :slight_smile:

Err :16 https://debian.snips.ai/stretch stable InRelease
Les signatures suivantes n’ont pas pu être vérifiées car la clé publique n’est pas disponible : NO_PUBKEY F727C778CCB0A455

Is there a new public key ?

#4

Change keyserver. Instead of pgp.mit.edu use keyserver.ubuntu.com

#5

Hi all,
I tried this procedure. I’m using Ubuntu 18.04.2 on an ASUS laptop model: K501U, using the integrated Intel sound card.
I have installed the platform, but as output audio, I have only Dummy Output so I can’t use other application to listen to the music while the assistant is working. I have tried to restart the snips services to release the resource but I receive only one error on the snips-audio-server about the sample rate.
This is the systemctl status report of the services after the restart:
https://pastebin.com/embed_js/SgaeebiW