Sam audio setup test fails to play microphone sound


#1

Hello,

i’m trying to set up my first raspberry pi 3 with snips with sam. Installation worked perfectly but there is a problem i can’t get fixed. The audio setup looks good everything is detected correct but when i am testing the microphone there is no sound playing. I testet two different USB soundcards so far and in Raspbian they are working fine and i can hear myself. sam test speaker also worked normal.

Any ideas?


#2

Hello Trubill,

I would need more information to pinpoint your issue. You could start by sending me the logs when you run sam test microphone.

What you can do in the meantime:
• I advise you to test the platform even if sam test microphone doesn’t output any sound. The test performed by Sam works like this: it records the audio and plays it back directly on the Pi. Sam runs shell commands on the Pi directly, it is not using Snips platform to perform those tests. Considering you can hear yourself directly in Raspbian, it could potentially work fine with the platform.

• If the platform doesn’t work, you’ll have to configure the audio manually. Check if the /etc/asound.conf configuration (device numbers) corresponds to the recording devices listed when you run arecord -l. More informations on this can be found in our documentation https://snips.gitbook.io/documentation/installing-snips/on-a-raspberry-pi#configuring-the-audio


#3

Hello Charles,

i tested it and it workes perfectly even when the audio test playback failed to play the recorded sound. thank you very much. when you do the test a hint that even when it fails it can work would be cool.


#4

Hello everybody

I am same problem, work on a pi and dont work with Sam-Cli
Any ideas ?


#5

Hi

I has the same problem, sound ok from services test but no sound from Sam test microphone.

I ran Sam setup audio, set my respeaker pi hat and it was ok :slight_smile:


#6

adding my name to the list.
I try many times from fresh install, all the same. sam test microphone failed. (speaker ok).
Thanks to Charles’ previous answer, i decide to finish the install. Snips is able to understand the intent so mic work.