Sam can't connect with my raspberry

Hi, I try to install Snip on my raspberry pi. when I tried to connect sam to my pi, I receive some errors.
1.Error:
sam devices
Scanning devices on the network…
i No devices discovered
But I have already connect with the LAN cable and it doesn’t want to connect.

2.Error
If I use the commando Sam connect 123.456.7.89
? Enter username for the device: pi
? Enter password for the device: [hidden]

:heavy_multiplication_x: Error connecting to 123.456.7.89: Timed out while waiting for handshake
Error: Cannot parse privateKey: Unsupported key format”

Has someone an idea to fix this stuff?

I use Mac os X.

Thanks in advance!

Hi @etzi !

I can’t connect with my raspberrypi either…I have the same first problem even if I’m not connected with LAN cable.

And I’ve tried many times with the command sam connect but every time the reponse is : Error connecting to 192.168.1.8: connect ECONNREFUSED 192.168.1.8:22

So I’m confused…Did you received some help ?
I’m on windows 10

Thank you guys !
(If it can help, I’m french)