SAM connection fails


#1

I’m new to snips and have installed it on a rpi3 and am trying to use SAM to communicate. When I do SAM devices it scans but comes back empty. I then use SAM connect with ip and it connects with no problem. I then do SAM init and i get the following message:
Connection failed, is your device turned on?
error: cannot parse privateKey: Unsupported key format

Any time I do a SAM command it gives me the same error message. I have Node.js 10.14.1 and npm 6.4.1… They seem to be working, but I do not know how to verify that.

I have loaded the platform demo on the rpi and I can say the hot word ‘Hey Snips’ and I get a tone response.

Any help from anyone would be greatly appreciated. Thanks in advance.


#2

Hello @crawfofdc

It was a bug due to an update of OSX that changed the format of the ssh key generated.

To solve the issue, update Sam, the fix is present since v0.0.44


#3

Charles, Thanks for your reply. I did an update on SAM it is now on v0.0.44, but I still have the same problem. I rebooted my rpi and made sure snips was running. This is what I get when I do a SAM status

x Connection failed, is your device turned on?
Error: Cannot parse privateKey: Unsupported key format

I removed the old authorzed_keys file and logged in with sam to the device using ip and it regenerated the file, but I still get the same error. Any other Ideas???

Thanks again.


#4

I am running SAM on a windows 10 machine. I have downloaded the git file as suggested on the install guide.


#5

Hi @crawfofdc,

You need to delete the SSH key present on your Windows machine so it can be regenerated. It is located in ~/.ssh/id_rsa_snips & ~/.ssh/id_rsa_snips.pub