Sam init not working anymore - authentification failed for packages

Hi everyone

snips was working fine untill i included a face reconnization. Then I had flush the SD Card and install snips all over again. But this time Sam won’t init.
I’ve run “sam init -v” to get details on the error, and this is the result


sam init -v
Installing Snips Platform components. This may take a few minutes…
Updating aptitude repository
OK:1 http/ /raspbian.raspberrypi .org/raspbian stretch InRelease
OK:2 http:/ /archive.raspberrypi .org/debian stretch InRelease
Holen:3 https:/ /raspbian.snips .ai/stretch stable InRelease [2.334 B]
Ign:3 https:/ /raspbian.snips .ai/stretch stable InRelease
Es wurden 2.334 B in 1 s geholt (2.183 B/s).
Paketlisten werden gelesen… (= package lists will be readed)
W: GPG-Fehler: https:/ /raspbian.snips .ai/stretch stable InRelease: Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY 531DD1A7B702B14D
W: The repository ‘https:/ /raspbian.snips .ai/stretch stable InRelease’ is not signed.
Installing dirmngr
Paketlisten werden gelesen…
Abhängigkeitsbaum wird aufgebaut…
Statusinformationen werden eingelesen…
dirmngr ist schon die neueste Version (2.1.18-8~deb9u4).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 201 nicht aktualisiert.
Adding Snips APT source list
Adding Snips PGP public key
Updating aptitude repository
OK:1 http:/ /raspbian.raspberrypi .org/raspbian stretch InRelease
OK:2 http:/ /archive.raspberrypi .org/debian stretch InRelease
Holen:3 https:/ /raspbian.snips .ai/stretch stable InRelease [2.334 B]
Ign:3 https:/ /raspbian.snips .ai/stretch stable InRelease
Es wurden 2.334 B in 1 s geholt (2.184 B/s).
Paketlisten werden gelesen…
W: GPG-Fehler: https:/ /raspbian.snips .ai/stretch stable InRelease: Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY 531DD1A7B702B14D
W: The repository ‘https:/ /raspbian.snips .ai/stretch stable InRelease’ is not signed.
Installing Snips Platform, this could take a while, grab a cup of tea & relax
Paketlisten werden gelesen…
Abhängigkeitsbaum wird aufgebaut…
Statusinformationen werden eingelesen…
The following additional packages will be installed:
libatlas3-base libev4 libttspico-data libttspico-utils libttspico0 libuv1
libwebsockets8 mosquitto snips-asr snips-audio-server snips-dialogue
snips-hotword snips-injection snips-kaldi-atlas snips-nlu
snips-platform-common snips-tts
Vorgeschlagene Pakete:
apparmor
Die folgenden NEUEN Pakete werden installiert:
libatlas3-base libev4 libttspico-data libttspico-utils libttspico0 libuv1
libwebsockets8 mosquitto snips-asr snips-audio-server snips-dialogue
snips-hotword snips-injection snips-kaldi-atlas snips-nlu
snips-platform-common snips-platform-voice snips-skill-server snips-template
snips-tts snips-watch
0 aktualisiert, 21 neu installiert, 0 zu entfernen und 201 nicht aktualisiert.
Es müssen 27,8 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 97,3 MB Plattenplatz zusätzlich benutzt.
WARNUNG: Die folgenden Pakete können nicht authentifiziert werden!
libatlas3-base snips-kaldi-atlas snips-platform-common snips-asr
snips-audio-server snips-dialogue snips-hotword snips-injection snips-nlu
snips-platform-voice snips-skill-server snips-template snips-tts snips-watch
E: There were unauthenticated packages and -y was used without --allow-unauthenticated
Adding current user to snips-skills-admin group for security
Disabling Mosquitto persistence
× Something went wrong during the installation process of one or more component
× snips-asr is missing
× snips-audio-server is missing
× snips-dialogue is missing
× snips-hotword is missing
× snips-nlu is missing
× snips-tts is missing
i Run sam init -v to enable verbose mode during installation process
i If you still encounter issues, ask for help on Snips’ forum: https://forum.snips.ai/

It seems there are some authentification problems.

Is there anything I can do?
(Btw: it was a pain to ‘remove’ the link message for this post. “New users can only post 2 links”)

Hello @BP-Kurii

Update Sam to fix the issue:
npm i -g snips-sam

We updated the PGP keys. This new version of Sam (v0.0.57) contains those PGP keys.

Thanks, everything is working now.

Hi all… I’m having (close) to the same problem. I noticed this on Oct 24th.

  1. sudo apt-get update wont work. Reports NO_PUBKEY 531DD1A7B702B14D. After some searches, this appears to be Buster related but I am on Stretch. I have not touched Buster.
  2. “sam update platform” will not upgrade snips like before. It will only update the OS.
  3. I also tried “npm i -g snips-sam”. Still sam init will not work. Just hangs after “snips.toml” question.
    I am trying to upgrade from 0.62.3

What should i do?

Hello @pianobill

  1. For the apt-get update to work, you need to delete the previous key(s) and add the new one:
sudo apt-key del D4F50CDCA10A2849
sudo apt-key del F727C778CCB0A455
sudo apt-key adv --fetch-keys  https://raspbian.snips.ai/531DD1A7B702B14D.pub
  1. The command is sam update
  2. If sam hangs on snips.toml, it means the file has changed and it needs your input. Sam doesn’t support this. It’s better to update manually on the device with
sudo apt-get update && sudo apt-get upgrade snips-platform-voice

Hi @Charles

Thx Sir. That did the trick. I am updated to 0.64.0

I am getting the same error. I tried to update but the same problem still happens. Is there something else I can do to fix the problem? Here is a screen shot of what I am getting. Thanks in advance.