Sam initしてもSnips Platform not installedのままになる(Checking with sam status will keep Snips Platform not installed.)


#1

こんにちは。
英語が苦手なので恐れながら、日本語で質問させてもらいます。
# Quick Start Raspberry Piに従って進めていく中で何点か問題がありました。

  1. sam devicesで表示されない
  2. sam initが中断される

1については、sam connect [ip]で接続できたので問題ないと思われます。
2については、同じようなトピックを探し
Error on “sam init”
を見つけました。
エラーは、この内容と同じことです。
対策としてmanual setupが書かれていたのでやってみましたが、sam statusで後から確認した際、not installedの状態です。
また、manual setup をすべてやってみましたが、エラーは出ていないのに全く動作しません。

情報を探してみたのですが、これ以上手に負えないので質問させていただきます。
Thanks


#2

NodeJSのバージョンは何ですか?私のは10.xであった前に、他の問題が出ていました。ターミナルでnode -vを入力したら、確認できますよ。写真やターミナルの内容も貼れば役に立ると思う。

私の苦手な日本語はすみませんでした。


#3

Lightさん。Replyありがとうございます。

バージョンは確認したところ以下の通りです。
node 10.14.2
npm 6.8.0
os Windows 10 Pro 64bit

こちら[Error on "sam init"]に投稿したようにファイルを一時的にコピーすることでsam initが完了しますが、sam statusで確認した際not installedになっています。
この操作によりHey snipsで反応するようになり、音は鳴るのですが返答が返って来ませんでした。
そこで、再起動したところ反応しなくなりました。


#4

バージョンは大丈夫そうですね。not installedというのは、assistantである可能性がありますか?私はHey snipsと言ったら反応が出ないから、追いつかなくてはいけませんよね。


#5

現状です。


#6

sam initのエラーは解消しましたが、いまだにsam statusで確認した際Snips Platform not installedになります。

This eliminates errors in sam init, but still checking with sam status will remain Snips Platform not installed.
google translation


#7

遅く返事してすみませんでした。忙しいでした。不思議ですね。直接に手伝い方が分かりませんですが、英語と日本語が訳せます。私はMORAさんのメッセジーを訳したいですか?
Sorry for my late reply, I was busy. That’s strange. I don’t know how to directly help, but I can translate English and Japanese. Do you want me to translate your messages?


#8

お忙しい中ありがとうございます。
忙しいのは人それぞれですから大丈夫です。
英語と日本語ができるとは、すごいです。なかなか書き方がわからないもので・・・
手伝っていただけるのであれば是非お願いしたいのですが、Lightさんのご都合もあると思うので気が向いたらで大丈夫です。
英語を書くことが苦手で読むほうはなんとなくできます。


#9

それにしても不思議です。
スタートアップ通りに作業を行い、sam initも成功するのにインストールされてないと言ってきます。
Raspbianも何回も初期化してやり直してきました。
他の方々の投稿を見てもインストールされた後の問題がほとんどなので、解決が難しそうです。


#10

すみませんでした。また大忙しくなりました。「Raspbianも何回も初期化してやり直してきました。」について、最新Raspbianを使ていないということですか?私は2018-11-13-raspbian-stretchを使っていると思いますよ。私はMORAさんのために英語のトッピクを作る方がいいですか?

I’m very sorry! I got really busy again. About “I have even restored Raspbian into an early version many times”, do you mean that you are not using the latest version of Raspbian? I think I’m using the “2018-11-13-raspbian-stretch” version.

Should I make an English topic for you?


#11

もしかして、 RaspbianをSDからではなくUSBからフラッシュ起動させているのが原因なのかもしれないことを最近疑っています。
試して見ようと思うので、それでも無理だったらお願いしたいと考えています。


#12

すみません、SDを使ていませんか?全部分かりませんでしたが、SDを使って試しましたが、無理でしたか?
I’m sorry, you aren’t using an SD card? I didn’t understand everything, but you tried using an SD card but it still didn’t work?


#13

まだ、SDカードを使って起動させていないので試そうと思います。
Debian系のバグがあるらしいので・・・
進展があったらここに書こうと思います。


#14

私は手伝えなくてすみませんね。頑張ってください。すぐその問題を超えるといいですね。


#15

大変長らくお待たせいたしました。
SDを使用し起動させたところテスト用アシスタントが正常に動作しました。
また、ステータスもLiveになりました。
多大なご迷惑をおかけしましたが、無事に解決することができました。
手伝っていただいたLightさんありがとうございました。
Thank you