Sam No Credentials Found


#1

Hi

I installed sam in Raspberry Pi 3 Model B+ on Raspbian OS.
When I tried the command sam init, it throws
Error: No credentials found

I have no idea what went wrong.

Thanks in advance.


#2

Did you do „Sam connect“?
Not sure if it was necessary if you use it local


#3

Thanks for replying. As I’m trying to use directly in Raspberry Pi, I think we don’t need to use sam connect. Anyway I tried.


#4

I have the same problem. If you found a solution let me know


#5

For me the credentials are still only useful for the connection: sam needs to know for what raspi your commands are ment to be - even if it’s local

As long as no one else has an idea:
Maybe try it with „sam connect localhost“ again? Or 127.0.0.1 (as you could not connect with the internal ip)

Google TTS requires credentials as well, but I think that was another prompt.


#6

It worked for me after configuring Raspberry Pi.


#7

Hello,

It is obligatory to use sam connect raspberrypi.local even if you run Sam directly on the Pi. Sam connects through SSH to the Pi.