SAM on virtual machine


#1

Hi
I want to try snips but I didn’t receive my HW right now.

My future setup is

  • snips server on a Debian vm
  • snips satellites with raspberry zero

So I successfully installed my server but didn’t configured audio options as I don’t need audio on my server.

I installed Sam too but when I try to discover snips installation it didn’t find anything.

Sam can’t find installations that aren’t on rpi?
Can I use Sam right now or must I wait to have my satellites ?

Thank for your help.


#2

can you connect directly to the vm via ip?
(sam connect IP)


#3

It works !

Thank…but now I have a problem when I try ‘sam init’

I already installed askpass and I tried to be sudo before but it didn’t change a thing.

Do you have an idea ?

Thank for your help.


#4

Ok I’ve found. Not a snips problem, only sudoers one.

You must specify NOPASSWD in sudo visudo


#5

When I do a ‘sam status’ everything service isn’t running and the last two (skill server and TTS) haven’t version number.

So when I try to install demo assistant, I have these errors


#6

Ok after many tries I’ve got everything running except audio-server, tts and skill-server.

My VM is only to process audio from satellites so it’s normal that audio-server and tts aren’t running right ?

What about skill-server ?


#7

Do you have any apps, that are served from snips? Do these apps have actions?

I do not have any actions in my skills and I also have no skill-server running.


#8

good point.

I tried to add meteo app to my assistant then use

sam install actions

But I’ve got this error

Error: Failed to stop snips-skill-server.service: Unit snips-skill-server.service not loaded.


#9

have you tried running the skill server yourself?

snips-skill-server -vvv

should do it


#10

Must I just use snips-skill-server -vvv ?

Because this command give
snips-skill-server : commande introuvable (not found)


#11

I retry for the x times this morning, here my steps from the begining (fresh debian netinstall with only ssh server)

su
apt-get install sudo -y
usermod -aG sudo *username*
sudo nano /etc/sudoers
ajouter *username*   ALL=(ALL) NOPASSWD: ALL

sudo apt-get install curl
curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash -
sudo apt-get install -y nodejs

sudo apt-get update
sudo apt-get install -y dirmngr apt-transport-https
sudo bash -c  'echo "deb https://debian.snips.ai/stretch stable main" > /etc/apt/sources.list.d/snips.list'
sudo apt-key adv --keyserver pgp.mit.edu --recv-keys F727C778CCB0A455
​
sudo apt-get update
sudo apt-get install -y snips-platform-voice

sudo npm install -g snips-sam
sudo apt-get install unzip

sam connect localhost
sam init
sam login
sam install assistant

Here my “sam status” result :

Audio server is off maybe because it’s a virtual machine without audio input. But I don’t get why TTS and skill-server aren’t install.

If I try

sudo apt-get install snips-skill-server

It doesn’t work with the message :

Thank for your help.


#12

Ok so I tried with a rpi3 + respeaker pi hat 2.

So I installed everything not only the audio part. I deploy my assistant (with app with and without actions ).

At the end, every services are running execpt…skill-server.

This time, it’s install but not running.

What the problem with this service ?

My skill server log

`snips-skill-server.service - Snips Skill Server
Loaded: loaded (/lib/systemd/system/snips-skill-server.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Wed 2018-11-07 07:28:04 UTC; 5s ago
Process: 8009 ExecStart=/usr/bin/snips-skill-server (code=exited, status=1/FAILURE)
Main PID: 8009 (code=exited, status=1/FAILURE)

Nov 07 07:28:04 raspberrypi systemd[1]: snips-skill-server.service: Unit entered failed state.
Nov 07 07:28:04 raspberrypi systemd[1]: snips-skill-server.service: Failed with result ‘exit-code’.
Nov 07 07:28:09 raspberrypi systemd[1]: snips-skill-server.service: Service hold-off time over, scheduling restart.
Nov 07 07:28:09 raspberrypi systemd[1]: Stopped Snips Skill Server.`

Edit : it’s ok on my Rpi3 with a different app but it still doesn’t work on my Debian virtual machine (not even installed).