SAM setup AEC... help


#1

I’ve got a Satellite with a Pi0 and Respeaker 2mic hat. I also have Squeezelite installed and was hoping at a minimum that the pulseaudio install as part of AEC from SAM would allow me to run Squeezelite and still let Snips TTS play.
Unfortunately after I ran the AEC setup in SAM, the mic works, but I get no audio.
I’ve gone through the few threads in the forum that discuss pulsaudio, but that didn’t help. Plus the SAM setup allows me to pick the correct speaker output and appears to finish correctly.
Has anyone else had trouble with the AEC setup from SAM or any suggestions?


#2

Really, no one has used “sam setup aec” on a Respeaker 2 mic hat?

I went back through and let sam setup the audio as a makers kit. Everything was working, so I re-ran sam setup aec and I’m back to the mic working but no sound.

After I first ran “sam setup aec” I was unable to get the snips-audio-server to start.
After a reboot, everything starts, the mic works, but I get no sound from sam test speaker.
If I SSH in and look at “pactl list sinks” I only see one option for alsa_output.platform-soc_audio.analog-stereo
I’ve tried going in and setting up Pulse for system wide, etc… but I’m at a loss since I only see the one option for output.