Satellite installieren, mit snips verknüpfen

Hallo allerseits,
Ich glaube ich denke gerade zu quer…
Kann mir jemand von euch sagen, wie ein Satellite mit snips kommuniziert?
Ich habe Snips auf einem Raspi 3b+ mit Respeaker 4, das klappt super.
Jetzt habe ich zusätzlich einen Raspi Zero mit Respeaker 2.

Was muss ich installieren und einstellen, damit der Zero,der in der Küche steht, mit dem SnIps im Wohnzimmer kommuniziert?

Irgendwie sehe ich den Wald vor lauter Bäume nicht :see_no_evil:

Vielen Dank für eure Hilfe

Gruß
Stefan

Einfach der Doku folgen:
https://docs.snips.ai/articles/platform/satellites
snips-satellite über apt-get installieren dann im Snips toml die aufgeführten Sachen wie die Adresse von der Base ausfüllen, im base toml die aufgeführten Parameter ändern.
Das Hotword Coalescing was unten erklärt wird kann Probleme geben weil die verschiedenen Respeaker Modelle unterschiedliche Delays haben. Das würde ich auslassen und eher was eigenes bauen.
Johannes

Hallo Joahnnes,

danke für den Link, habe das irgendwie nicht gefunden.
Ich bekomme aber ein Paket nicht installiert, weil er es nicht findet :frowning:

pi@snips_kueche:~ $ sudo apt install snips-hotword-model-heysnipsv4
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Paket snips-hotword-model-heysnipsv4 kann nicht gefunden werden.

Hast ne Idee wie ich das installieren kann ?
Habe ich etwas vergessen vorher zu installieren ?

Vielen Dank

Gruß
Stefan

Ein

pi@snips_kueche:~ $ sudo apt update
OK:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Holen:2 http://archive.raspberrypi.org/debian stretch InRelease [25,4 kB]
Holen:3 https://raspbian.snips.ai/stretch stable InRelease [2.334 B]
Fehl:3 https://raspbian.snips.ai/stretch stable InRelease       
  Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY 531DD1A7B702B14D
Paketlisten werden gelesen... Fertig
W: GPG-Fehler: https://raspbian.snips.ai/stretch stable InRelease: Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY 531DD1A7B702B14D
E: The repository 'https://raspbian.snips.ai/stretch stable InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

sagt das irgendein Key nicht öffentlich ist ?
Verstehe ich nicht :frowning:

ok, der Satelite lässt sich nicht mit Raspbian Stretch installieren, ich werde mal Upgraden auf Buster, dort schein es das Paket "snips-hotword-model-heysnipsv4 "noch zu geben…

Wenn jemand eine andere Idee hat, gern her damit…

Edit,
Hmm nee Buster wird ja offiziell noch gar nicht unterstützt.

Aber das Paket (snips-hotword-model-heysnipsv4 ) welches ich installieren soll, gibt es für Stretch nicht mehr

Hey Cetax,
führe mal auf deinem snips_kueche das hier aus:

sudo bash -c 'echo "deb [trusted=yes] https://raspbian.snips.ai/stretch stable main" > /etc/apt/sources.list.d/snips.list'

Damit wird das [trusted=yes] noch in die Paketquellen-Datei dazugeschrieben, was den Fehler mit dem Key nicht mehr auftreten lässt. Eigentlich sollte dann auch nach einem sudo apt update das Paket wieder da sein.

@atomix super, hat geklappt, vielen dank :+1:

Bis eben hat alles so funktioniert wie es soll…
Aber dann hab ich blödman ein “Sam init” auf dem Satellite durch geführt :see_no_evil:

Nun höre ich auf dem Master alles doppelt und auf dem Satellite nix mehr und er regiert auch nicht mehr…

Kann ich das “Sam init” irgendwie wieder rückgängig machen ?
oder muss ich den Satellite löschen und neu machen ?

Gruß
Stefan

@Cetax Der init-Befehl müsste die Snips Pakete installiert haben, also wurden dann neben dem Paket snips-satellite dann die Pakete snips-audio-server, snips-asr, etc. installiert, die jetzt auch auf dem Satellite aktiv sind. Daher wahrscheinlich die Fehlfunktion. Also mal das hier auf dem Satellite ausführen:

sudo apt remove snips-asr snips-nlu snips-dialogue snips-audio-server snips-injection snips-hotword snips-tts

Es wurde vielleicht auch die Datei /etc/snips.toml verändert, also da am besten nochmal drüberschauen und die gewünschte Kofiguration wieder einstellen.

Gruß
Atomix

@atomix super , vielen Dank :+1:
Hat geklappt, jetzt läuft er wieder wie er soll.

Gruß
Stefan

1 Like