Satellites losing connection [solved]


#1

Hi all,

I’ve started tinkering with snips and homeassistant and like it.
Now I added satellites according to the documentation (Raspberry Pi Z; setup B, hotword/audio-server on satellite).
It works but the satellites keep losing the connection to the mqtt server on the main snips-server (Raspberry Pi 3 B+).

These are the last two lines of the snips-hotword service log:

Feb 04 17:50:42 snips-satellite-wz snips-hotword[2485]: ERROR:rumqtt::client : snips-hotword|2485-snips-satellite-wz-1 Disconnected: (Error(Msg(“socket closed”), State { next_error: None, backtrace: None }))
Feb 04 17:51:26 snips-satellite-wz snips-hotword[2485]: ERROR:rumqtt::client : snips-hotword|2485-snips-satellite-wz-1 Disconnected: (Error(InvalidState, State { next_error: None, backtrace: None }))

Any ideas anyone?


#2

Is you power management on for wifi connection ? …


#3

iwconfig seems to think so. Some sources say the chip doesn’t support pm and iwconfig doesn’t know what its talking about.
Anyway I was able to run “iwconfig wlan0 power off” without errors. So I’m waiting to see if it helps.
What’s curious to me though is that I was always able to connect with ssh via wifi.


#4

So … I don’t think that was the problem.
As I said I disabled power management with iwconfig (on satellite and server) but the satellite ran into the same issue (except it only logged the second error).

P.S: When I call iwconfig I still see “Power Management:off”


#5

I think I solved it.
After a couple of days monitoring the problem, I realised that it usually happened around the same time my router reconnects the internet connection at night (this is a relict from the time when the providers cut the connection after 25 hours or so).
Because I noticed before that SSH always showed me my IPv6-address as “last connected from” I thought it might have something to do with my router getting and distributing a new IPv6 prefix.
I disabled IPv6 on the raspberries (no problem in a small private network) and it seems to have helped. Only 1 out of 3 satellites still has a similar problem but I guess it is something else.