Snips-audio-server bug after upgrading

Hello,
I just upgraded to 0.64.
All works fine beside the audio server part - snips start to speak and stops after the first word.

Before upgrading it was working fine.

I’m running snips on RPI 3B+ and a respeaker 4-mic array

my asound.conf file is

pcm.jack{
type hw
card 
device 0
rate 16000
}
pcm.!default{
type asym
playback.pcm{
type plug
slave.pcm "jack"
}
capture.pcm{
type plug
slave.pcm "hw:1,0"
}
}

and have this lines in snips.toml

[snips-audio-server]
alsa_capture = "default"
alsa_playback = "default"

Any idea how to fix it?

Hello,

Could you provide some logs plz? Thanks

[05:52:07.699151] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.no_exit_on_all_panics -> Ok(None)
[05:52:07.699737] DEBUG:snips_common_cli::cli: conf lookup: snips-common.no_exit_on_all_panics -> Ok(None)
[05:52:07.699999] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.bus -> Ok(None)
[05:52:07.700234] DEBUG:snips_common_cli::cli: conf lookup: snips-common.bus -> Ok(Some("mqtt"))
[05:52:07.700502] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.mqtt -> Ok(None)
[05:52:07.700712] DEBUG:snips_common_cli::cli: conf lookup: snips-common.mqtt -> Ok(Some("192.168.1.105:1883"))
[05:52:07.700989] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.mqtt_username -> Ok(None)
[05:52:07.701174] DEBUG:snips_common_cli::cli: conf lookup: snips-common.mqtt_username -> Ok(Some("mqtt_login"))
[05:52:07.701365] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.mqtt_password -> Ok(None)
[05:52:07.701549] DEBUG:snips_common_cli::cli: conf lookup: snips-common.mqtt_password -> Ok(Some("kurkum"))
[05:52:07.701737] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.mqtt_tls_hostname -> Ok(None)
[05:52:07.701921] DEBUG:snips_common_cli::cli: conf lookup: snips-common.mqtt_tls_hostname -> Ok(None)
[05:52:07.702175] DEBUG:rumqtt::client       : snips-audio-server|8095-raspberrypi-1: Client start
[05:52:07.702436] INFO :rumqtt::connection   : snips-audio-server|8095-raspberrypi-1: Connection start
[05:52:07.702669] DEBUG:rumqtt::connection   : snips-audio-server|8095-raspberrypi-1 new connection
[05:52:07.703729] DEBUG:rumqtt::connection   : Send: Connect(Connect { protocol: MQTT(4), keep_alive: 10, client_id: "snips-audio-server|8095-raspberrypi-1", clean_session: false, last_will: None, username: Some("mqtt_login"), password: Some("kurkum") })
[05:52:07.704930] DEBUG:rumqtt::connection   : snips-audio-server|8095-raspberrypi-1 Received control message Connack(Connack { session_present: false, code: Accepted })
[05:52:07.705230] INFO :rumqtt::connection   : snips-audio-server|8095-raspberrypi-1: Connection established
[05:52:07.705462] DEBUG:rumqtt::client       : snips-audio-server|8095-raspberrypi-1: Spawning client thread
[05:52:07.705936] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.disable_playback -> Ok(None)
[05:52:07.706017] DEBUG:rumqtt::client       : snips-audio-server|8095-raspberrypi-1: Entering normal operation loop
[05:52:07.706262] DEBUG:snips_common_cli::cli: conf lookup: snips-common.disable_playback -> Ok(None)
[05:52:07.706594] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.alsa_playback -> Ok(None)
[05:52:07.706779] DEBUG:snips_common_cli::cli: conf lookup: snips-common.alsa_playback -> Ok(None)
[05:52:07.706967] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.portaudio_playback -> Ok(None)
[05:52:07.707152] DEBUG:snips_common_cli::cli: conf lookup: snips-common.portaudio_playback -> Ok(None)
[05:52:07.707335] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.output -> Ok(None)
[05:52:07.707550] DEBUG:snips_common_cli::cli: conf lookup: snips-common.output -> Ok(None)
[05:52:07.707791] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.frame -> Ok(None)
[05:52:07.708024] DEBUG:snips_common_cli::cli: conf lookup: snips-common.frame -> Ok(None)
[05:52:07.708260] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.disable_capture -> Ok(None)
[05:52:07.708496] DEBUG:snips_common_cli::cli: conf lookup: snips-common.disable_capture -> Ok(None)
[05:52:07.708742] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.nomike -> Ok(None)
[05:52:07.708974] DEBUG:snips_common_cli::cli: conf lookup: snips-common.nomike -> Ok(None)
[05:52:07.709210] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.portaudio_capture -> Ok(None)
[05:52:07.709445] DEBUG:snips_common_cli::cli: conf lookup: snips-common.portaudio_capture -> Ok(None)
[05:52:07.709656] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.mike -> Ok(None)
[05:52:07.709838] DEBUG:snips_common_cli::cli: conf lookup: snips-common.mike -> Ok(None)
[05:52:07.710021] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.alsa_capture -> Ok(None)
[05:52:07.710220] DEBUG:snips_common_cli::cli: conf lookup: snips-common.alsa_capture -> Ok(None)
[05:52:07.710448] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.hijack -> Ok(None)
[05:52:07.710682] DEBUG:snips_common_cli::cli: conf lookup: snips-common.hijack -> Ok(None)
[05:52:07.710921] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.bind -> Ok(Some("master_bedroom@mqtt"))
[05:52:07.711169] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.bind -> Ok(Some("master_bedroom@mqtt"))
[05:52:07.711422] INFO :snips_audio_server_cli: Starting audio server on mqtt for site master_bedroom
[05:52:07.711812] DEBUG:snips_audio_alsa::capture: Attempt 0
[05:52:07.711927] DEBUG:snips_audio_alsa::capture: ALSA capture source started
[05:52:07.712140] DEBUG:snips_audio_alsa::capture: List ALSA capture devices
[05:52:07.741180] DEBUG:snips_audio_alsa::capture:  -  Hint { name: Some("null"), desc: Some("Discard all samples (playback) or generate zero samples (capture)"), direction: None }
[05:52:07.741292] DEBUG:snips_audio_alsa::capture:  -  Hint { name: Some("default"), desc: None, direction: None }
[05:52:07.741416] DEBUG:snips_audio_alsa::capture:  -  Hint { name: Some("sysdefault:CARD=seeed4micvoicec"), desc: Some("seeed-4mic-voicecard, \nDefault Audio Device"), direction: Some(Capture) }
[05:52:07.741467] DEBUG:snips_audio_alsa::capture:  -  Hint { name: Some("dmix:CARD=seeed4micvoicec,DEV=0"), desc: Some("seeed-4mic-voicecard, \nDirect sample mixing device"), direction: Some(Capture) }
[05:52:07.741516] DEBUG:snips_audio_alsa::capture:  -  Hint { name: Some("dsnoop:CARD=seeed4micvoicec,DEV=0"), desc: Some("seeed-4mic-voicecard, \nDirect sample snooping device"), direction: Some(Capture) }
[05:52:07.741564] DEBUG:snips_audio_alsa::capture:  -  Hint { name: Some("hw:CARD=seeed4micvoicec,DEV=0"), desc: Some("seeed-4mic-voicecard, \nDirect hardware device without any conversions"), direction: Some(Capture) }
[05:52:07.741617] DEBUG:snips_audio_alsa::capture:  -  Hint { name: Some("plughw:CARD=seeed4micvoicec,DEV=0"), desc: Some("seeed-4mic-voicecard, \nHardware device with all software conversions"), direction: Some(Capture) }
[05:52:07.741666] INFO :snips_audio_alsa::capture: Starting ALSA capture on device "default"
[05:52:07.742224] DEBUG:snips_audio_alsa::capture: ALSA capture source ended
[05:52:07.812166] DEBUG:snips_audio_alsa::capture: Attempt 1
[05:52:07.812380] ERROR:snips_audio_server       : an error occured in the audio pipeline: Error("snd_pcm_open", Sys(EBUSY))
 -> caused by: ALSA function 'snd_pcm_open' failed with error 'EBUSY: Device or resource busy'

I’m using an external MQTT (in a different pi running HASS.IO)

[05:56:31.385047] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.no_exit_on_all_panics -> Ok(None)
[05:56:31.385286] DEBUG:snips_common_cli::cli: conf lookup: snips-common.no_exit_on_all_panics -> Ok(None)
[05:56:31.385329] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.bus -> Ok(None)
[05:56:31.385365] DEBUG:snips_common_cli::cli: conf lookup: snips-common.bus -> Ok(Some("mqtt"))
[05:56:31.385427] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.mqtt -> Ok(None)
[05:56:31.385461] DEBUG:snips_common_cli::cli: conf lookup: snips-common.mqtt -> Ok(Some("192.168.1.105:1883"))
[05:56:31.385584] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.mqtt_username -> Ok(None)
[05:56:31.385665] DEBUG:snips_common_cli::cli: conf lookup: snips-common.mqtt_username -> Ok(Some("mqtt_login"))
[05:56:31.386160] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.mqtt_password -> Ok(None)
[05:56:31.386209] DEBUG:snips_common_cli::cli: conf lookup: snips-common.mqtt_password -> Ok(Some("kurkum"))
[05:56:31.386254] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.mqtt_tls_hostname -> Ok(None)
[05:56:31.386290] DEBUG:snips_common_cli::cli: conf lookup: snips-common.mqtt_tls_hostname -> Ok(None)
[05:56:31.386761] DEBUG:rumqtt::client       : snips-audio-server|8594-raspberrypi-1: Client start
[05:56:31.386799] INFO :rumqtt::connection   : snips-audio-server|8594-raspberrypi-1: Connection start
[05:56:31.386831] DEBUG:rumqtt::connection   : snips-audio-server|8594-raspberrypi-1 new connection
[05:56:31.387685] DEBUG:rumqtt::connection   : Send: Connect(Connect { protocol: MQTT(4), keep_alive: 10, client_id: "snips-audio-server|8594-raspberrypi-1", clean_session: false, last_will: None, username: Some("mqtt_login"), password: Some("kurkum") })
[05:56:31.388708] DEBUG:rumqtt::connection   : snips-audio-server|8594-raspberrypi-1 Received control message Connack(Connack { session_present: false, code: Accepted })
[05:56:31.388900] INFO :rumqtt::connection   : snips-audio-server|8594-raspberrypi-1: Connection established
[05:56:31.389022] DEBUG:rumqtt::client       : snips-audio-server|8594-raspberrypi-1: Spawning client thread
[05:56:31.389357] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.disable_playback -> Ok(None)
[05:56:31.389409] DEBUG:snips_common_cli::cli: conf lookup: snips-common.disable_playback -> Ok(None)
[05:56:31.389433] DEBUG:rumqtt::client       : snips-audio-server|8594-raspberrypi-1: Entering normal operation loop
[05:56:31.389448] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.alsa_playback -> Ok(None)
[05:56:31.389481] DEBUG:snips_common_cli::cli: conf lookup: snips-common.alsa_playback -> Ok(None)
[05:56:31.389770] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.portaudio_playback -> Ok(None)
[05:56:31.389895] DEBUG:snips_common_cli::cli: conf lookup: snips-common.portaudio_playback -> Ok(None)
[05:56:31.390124] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.output -> Ok(None)
[05:56:31.390244] DEBUG:snips_common_cli::cli: conf lookup: snips-common.output -> Ok(None)
[05:56:31.390399] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.frame -> Ok(None)
[05:56:31.390520] DEBUG:snips_common_cli::cli: conf lookup: snips-common.frame -> Ok(None)
[05:56:31.390644] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.disable_capture -> Ok(None)
[05:56:31.390785] DEBUG:snips_common_cli::cli: conf lookup: snips-common.disable_capture -> Ok(None)
[05:56:31.390912] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.nomike -> Ok(None)
[05:56:31.391057] DEBUG:snips_common_cli::cli: conf lookup: snips-common.nomike -> Ok(None)
[05:56:31.391161] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.portaudio_capture -> Ok(None)
[05:56:31.391259] DEBUG:snips_common_cli::cli: conf lookup: snips-common.portaudio_capture -> Ok(None)
[05:56:31.391356] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.mike -> Ok(None)
[05:56:31.391448] DEBUG:snips_common_cli::cli: conf lookup: snips-common.mike -> Ok(None)
[05:56:31.391543] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.alsa_capture -> Ok(None)
[05:56:31.391637] DEBUG:snips_common_cli::cli: conf lookup: snips-common.alsa_capture -> Ok(None)
[05:56:31.391734] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.hijack -> Ok(None)
[05:56:31.391827] DEBUG:snips_common_cli::cli: conf lookup: snips-common.hijack -> Ok(None)
[05:56:31.391925] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.bind -> Ok(Some("master_bedroom@mqtt"))
[05:56:31.392032] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.bind -> Ok(Some("master_bedroom@mqtt"))
[05:56:31.392175] INFO :snips_audio_server_cli: Starting audio server on mqtt for site master_bedroom
[05:56:31.392418] DEBUG:snips_audio_alsa::capture: Attempt 0
[05:56:31.392520] DEBUG:snips_audio_alsa::capture: ALSA capture source started
[05:56:31.392573] DEBUG:snips_audio_alsa::capture: List ALSA capture devices
[05:56:31.415767] DEBUG:snips_audio_alsa::capture:  -  Hint { name: Some("null"), desc: Some("Discard all samples (playback) or generate zero samples (capture)"), direction: None }
[05:56:31.415874] DEBUG:snips_audio_alsa::capture:  -  Hint { name: Some("default"), desc: None, direction: None }
[05:56:31.415980] DEBUG:snips_audio_alsa::capture:  -  Hint { name: Some("sysdefault:CARD=seeed4micvoicec"), desc: Some("seeed-4mic-voicecard, \nDefault Audio Device"), direction: Some(Capture) }
[05:56:31.416022] DEBUG:snips_audio_alsa::capture:  -  Hint { name: Some("dmix:CARD=seeed4micvoicec,DEV=0"), desc: Some("seeed-4mic-voicecard, \nDirect sample mixing device"), direction: Some(Capture) }
[05:56:31.416063] DEBUG:snips_audio_alsa::capture:  -  Hint { name: Some("dsnoop:CARD=seeed4micvoicec,DEV=0"), desc: Some("seeed-4mic-voicecard, \nDirect sample snooping device"), direction: Some(Capture) }
[05:56:31.416104] DEBUG:snips_audio_alsa::capture:  -  Hint { name: Some("hw:CARD=seeed4micvoicec,DEV=0"), desc: Some("seeed-4mic-voicecard, \nDirect hardware device without any conversions"), direction: Some(Capture) }
[05:56:31.416183] DEBUG:snips_audio_alsa::capture:  -  Hint { name: Some("plughw:CARD=seeed4micvoicec,DEV=0"), desc: Some("seeed-4mic-voicecard, \nHardware device with all software conversions"), direction: Some(Capture) }
[05:56:31.416248] INFO :snips_audio_alsa::capture: Starting ALSA capture on device "default"
[05:56:31.416799] DEBUG:snips_audio_alsa::capture: ALSA capture source ended
[05:56:31.492528] DEBUG:snips_audio_alsa::capture: Attempt 1
[05:56:31.492916] ERROR:snips_audio_server       : an error occured in the audio pipeline: Error("snd_pcm_open", Sys(EBUSY))
 -> caused by: ALSA function 'snd_pcm_open' failed with error 'EBUSY: Device or resource busy'

[05:56:31.492940] ERROR:rumqtt::client           : snips-audio-server|8594-raspberrypi-1 Disconnected: (Error(SyncMpsc(Disconnected), State { next_error: None, backtrace: None }))
[05:56:31.493050] DEBUG:rumqtt::client           : snips-audio-server|8594-raspberrypi-1: Entering reconnecting loop
[05:56:31.493103] INFO :rumqtt::client           : not seeking reconnection
[05:56:31.493153] INFO :rumqtt::client           : client thread done
[05:56:31.493202] ERROR:snips_common_cli::cli    : Unable to reconnect to the mqtt broker, ending the program.

Hi,

to check your issue, we need the followings logs taken when the problems occurs

snips-watch -vvv
sudo systemctl stop snips-audio-server
sudo -u _snips snips-audio-server -v

In the log you posted there is this line,

[05:56:31.492916] ERROR:snips_audio_server       : an error occured in the audio pipeline: Error("snd_pcm_open", Sys(EBUSY)) -> caused by: ALSA function 'snd_pcm_open' failed with error 'EBUSY: Device or resource busy'

It indicates that the audio playback interface is already in use.

If your configuration was working just fine before and you want to avoid the audio troubleshooting, you can also try to fallback to the portaudio audio backend.

in your configuration file /etc/snips.toml, in the snips-audio-server section, add portaudio_playback = “default”

1 Like

snips-watch -vvv

[07:33:48] Watching on 192.168.1.105:1883 (MQTT)
[07:33:51] [Hotword] detected on site master_bedroom, for model hey_snips
[07:33:51] [Asr] was asked to stop listening on site master_bedroom
[07:33:51] [Hotword] was asked to toggle itself 'off' on site master_bedroom
[07:33:51] [Dialogue] session with id '6d4c07a8-5301-4422-9eae-52540e72a864' was started on site master_bedroom
[07:33:51] [AudioServer] was asked to play a wav of 41.1 kB with id 'a73ba101-6276-4be6-ae1f-76443a6f854b' on site master_bedroom
[07:33:51] [AudioServer] finished playing wav with id 'a73ba101-6276-4be6-ae1f-76443a6f854b'
[07:33:51] [Asr] was asked to listen on site master_bedroom
[07:33:55] [Asr] captured text "turn on bed lights" in 3.0s
[07:33:55] [Asr] was asked to stop listening on site master_bedroom
[07:33:55] [AudioServer] was asked to play a wav of 93.1 kB with id 'ab571c08-6699-4471-81a5-0e1c77d19eaa' on site master_bedroom
[07:33:55] [AudioServer] finished playing wav with id 'ab571c08-6699-4471-81a5-0e1c77d19eaa'
[07:33:55] [Nlu] was asked to parse input "turn on bed lights"
[07:33:55] [Nlu] detected intent dror-israel:TurnOnLights with confidence score 1.000 for input "turn on bed lights"
              Slots ->
                 LightSlot -> bed (confidence: 1.000)
[07:33:55] [Dialogue] New intent detected dror-israel:TurnOnLights with confidence 1.000
              Slots ->
                 LightSlot -> bed (confidence: 1.000)
[07:33:55] [Dialogue] was ask to end session with id 6d4c07a8-5301-4422-9eae-52540e72a864 by saying 'Turning on bed lights'
[07:33:55] [Tts] was asked to say "Turning on bed lights"
[07:33:56] [Tts] finished speaking with id '73408fbb-01d6-41a5-8027-413ff434727a'
[07:33:56] [Dialogue] session with id '6d4c07a8-5301-4422-9eae-52540e72a864' was ended on site master_bedroom. The session ended as expected
[07:33:56] [Asr] was asked to stop listening on site master_bedroom
[07:33:56] [Hotword] was asked to toggle itself 'on' on site master_bedroom

sudo -u _snips snips-audio-server -v

[07:36:27.310014] DEBUG:snips_audio_server_hermes::player: Playing bytes 43cef67d-f1b0-46a4-aa4c-16c31484fe27
[07:36:27.313076] INFO :snips_audio_alsa::playback       : Using ALSA output None ("bcm2835 ALSA") for "43cef67d-f1b0-46a4-aa4c-16c31484fe27", WavSpec { channels: 2, sample_rate: 22050, bits_per_sample: 16, sample_format: Int }
[07:36:27.376153] INFO :snips_audio_alsa::playback       : Playback for 43cef67d-f1b0-46a4-aa4c-16c31484fe27 finished
[07:36:27.376466] DEBUG:snips_audio_server_hermes::player: Finished Playing bytes 43cef67d-f1b0-46a4-aa4c-16c31484fe27
[07:36:30.216229] DEBUG:snips_audio_server_hermes::player: Playing bytes 21cdc0ea-24bb-4fd0-b03e-e3f30b3a0aca
[07:36:30.219600] INFO :snips_audio_alsa::playback       : Using ALSA output None ("bcm2835 ALSA") for "21cdc0ea-24bb-4fd0-b03e-e3f30b3a0aca", WavSpec { channels: 2, sample_rate: 22050, bits_per_sample: 16, sample_format: Int }
[07:36:30.286180] INFO :snips_audio_alsa::playback       : Playback for 21cdc0ea-24bb-4fd0-b03e-e3f30b3a0aca finished
[07:36:30.286772] DEBUG:snips_audio_server_hermes::player: Finished Playing bytes 21cdc0ea-24bb-4fd0-b03e-e3f30b3a0aca
[07:36:30.488751] DEBUG:snips_audio_server_hermes::player: Playing stream ed3fab9a-dac1-474a-8e0d-62c7b36b88f3
[07:36:30.488865] DEBUG:snips_audio_alsa::playback       : playing stream ed3fab9a-dac1-474a-8e0d-62c7b36b88f3
[07:36:30.488894] DEBUG:snips_audio_alsa::playback       : got playback lock
[07:36:30.491444] INFO :snips_audio_alsa::playback       : Using ALSA output None ("bcm2835 ALSA") for "ed3fab9a-dac1-474a-8e0d-62c7b36b88f3", WavSpec { channels: 1, sample_rate: 16000, bits_per_sample: 16, sample_format: Int }
[07:36:30.916152] INFO :snips_audio_alsa::playback       : Playback for ed3fab9a-dac1-474a-8e0d-62c7b36b88f3 finished
[07:36:30.916799] DEBUG:snips_audio_server_hermes::player: Finished playing stream ed3fab9a-dac1-474a-8e0d-62c7b36b88f3

@dror-israel you are not alone:

My setup also broke with the update, the satellites are running an old version and assistant and are still working (even together with the updated base).

However your logs look much better than mine, I get errors before intents are detected.

Regards,
Thomas

@dror-israel
From the log perspective, it looks like ok.

What is exactly the issue?
Instead of saying “Turning on bed lights”, it says “Turn…” ?

@HorizonKane
Audio can be tricky, the reason and way to solve those problem can vary depending on the configuration.

Sakana if you look at the other thread, you can see that this is not a configuration issue. All my audio setup is fineand the same as prior to the upgrade. Sam test speaker is working great. This problem only occurs on the new version.

Drors setup was also working before the update. However I must admit that dror might have another problem as he does net get the same error in the logs. However he also has the crippled voice.

And what else should I change on my config? It’s a stretch lite with nothing else than npm, sam, Snips (which was working great prior to upgrade). I didn’t even install a driver for the usb ps eye that I could update or something…

Has I said, We changed the default behavior of the audio-server to use alsa as the default backend.

It works great on makerkit using PiHat (our base reference) tough it can maybe cause issue on other configuration.

Try to switch to portaudio if you want to fall back on the former behavior.

Hi Sakana,

thanks for your help. For my problem I focus on the other thread, to not confuse us :slight_smile:

try to retrain and reinstall your assistant

This is the issue indeed.
I added portaudio_playback = “default” and now it is sometimes working and sometimes not.

Hi @dror-israel,

Your issue has been referenced on snips-issues

the current workaround is to downgrade snips-audio-server and snips-tts to version 0.63.3 (and snips-satellite as well if you are using it)