Snips-audio-server fails to start on ubuntu 18.04 on a pi with respeaker piHat2

respeaker

#1

I have snips maker (respeaker 2-Mic Hat) and try to run snips on ubuntu 18.04 aarch 64
(http://cdimage.ubuntu.com/releases/18.04/release/ubuntu-18.04.2-preinstalled-server-arm64+raspi3.img.xz)
I have installed manually snips 0.60.12 and manage also to install manually respeaker driver successfully
Running sam test audio and sam test microphone, test successfully, however snips-audio-server keeps falling
Other snips service is working, only this snips-audio-server keeps falling

root@ubuntu:~# snips-audio-server -vvv
[14:17:35.380588] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.frame -> Ok(None)
[14:17:35.382536] DEBUG:snips_common_cli::cli: conf lookup: snips-common.frame -> Ok(None)
[14:17:35.382622] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.nomike -> Ok(None)
[14:17:35.382657] DEBUG:snips_common_cli::cli: conf lookup: snips-common.nomike -> Ok(None)
[14:17:35.382697] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.mike -> Ok(None)
[14:17:35.382730] DEBUG:snips_common_cli::cli: conf lookup: snips-common.mike -> Ok(None)
[14:17:35.382864] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.bind -> Ok(None)
[14:17:35.382900] DEBUG:snips_common_cli::cli: conf lookup: snips-common.bind -> Ok(None)
[14:17:35.382946] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.disable_capture -> Ok(None)
[14:17:35.383047] DEBUG:snips_common_cli::cli: conf lookup: snips-common.disable_capture -> Ok(None)
[14:17:35.383089] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.alsa_capture -> Ok(None)
[14:17:35.383156] DEBUG:snips_common_cli::cli: conf lookup: snips-common.alsa_capture -> Ok(None)
[14:17:35.383193] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.hijack -> Ok(None)
[14:17:35.383227] DEBUG:snips_common_cli::cli: conf lookup: snips-common.hijack -> Ok(None)
[14:17:35.383265] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.bind -> Ok(None)
[14:17:35.383296] DEBUG:snips_common_cli::cli: conf lookup: snips-common.bind -> Ok(None)
[14:17:35.383341] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.bus -> Ok(None)
[14:17:35.383369] DEBUG:snips_common_cli::cli: conf lookup: snips-common.bus -> Ok(None)
[14:17:35.383405] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.mqtt -> Ok(None)
[14:17:35.383443] DEBUG:snips_common_cli::cli: conf lookup: snips-common.mqtt -> Ok(None)
[14:17:35.383748] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.mqtt_username -> Ok(None)
[14:17:35.383797] DEBUG:snips_common_cli::cli: conf lookup: snips-common.mqtt_username -> Ok(None)
[14:17:35.383837] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.mqtt_password -> Ok(None)
[14:17:35.383872] DEBUG:snips_common_cli::cli: conf lookup: snips-common.mqtt_password -> Ok(None)
[14:17:35.383912] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.mqtt_tls_hostname -> Ok(None)
[14:17:35.383958] DEBUG:snips_common_cli::cli: conf lookup: snips-common.mqtt_tls_hostname -> Ok(None)
[14:17:35.384074] DEBUG:rumqtt::client : snips-audio-server|10653-ubuntu-1: Client start
[14:17:35.384128] INFO :rumqtt::connection : snips-audio-server|10653-ubuntu-1: Connection start
[14:17:35.384167] DEBUG:rumqtt::connection : snips-audio-server|10653-ubuntu-1 new connection
[14:17:35.385701] DEBUG:rumqtt::connection : Send: Connect(Connect { protocol: MQTT(4), keep_alive: 10, client_id: “snips-audio-server|10653-ubuntu-1”, clean_session: false, last_will: None, username: None, password: None })
[14:17:35.395222] DEBUG:rumqtt::connection : snips-audio-server|10653-ubuntu-1 Received control message Connack(Connack { session_present: true, code: Accepted })
[14:17:35.395370] INFO :rumqtt::connection : snips-audio-server|10653-ubuntu-1: Connection established
[14:17:35.395405] DEBUG:rumqtt::client : snips-audio-server|10653-ubuntu-1: Spawning client thread
[14:17:35.395808] INFO :snips_audio_server : Starting audio server on mqtt for site default
[14:17:35.395989] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.alsa_playback -> Ok(None)
[14:17:35.396059] DEBUG:rumqtt::client : snips-audio-server|10653-ubuntu-1: Entering normal operation loop
[14:17:35.396296] DEBUG:snips_common_cli::cli: conf lookup: snips-common.alsa_playback -> Ok(None)
[14:17:35.396393] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.disable_playback -> Ok(None)
[14:17:35.396473] DEBUG:snips_common_cli::cli: conf lookup: snips-common.disable_playback -> Ok(None)
[14:17:35.396550] DEBUG:snips_common_cli::cli: conf lookup: snips-audio-server.output -> Ok(None)
[14:17:35.396669] DEBUG:snips_common_cli::cli: conf lookup: snips-common.output -> Ok(None)
[14:17:35.396730] INFO :snips_audio_server : Capture enabled: true, Playback enabled: true
[14:17:35.397038] INFO :snips_broadcast_mqtt_server: Starting broadcasting audio on hermes as site “default”
[14:17:35.397018] DEBUG:rumqtt::connection : Send: Subscribe(Subscribe { pid: PacketIdentifier(1), topics: [SubscribeTopic { topic_path: “hermes/audioServer/default/playBytes/#”, qos: AtMostOnce }] })
[14:17:35.397349] DEBUG:rumqtt::connection : Send: Subscribe(Subscribe { pid: PacketIdentifier(2), topics: [SubscribeTopic { topic_path: “hermes/audioServer/toggleOn”, qos: AtMostOnce }] })
[14:17:35.397421] DEBUG:snips_audio_portaudio : Attempt 0
[14:17:35.397797] DEBUG:rumqtt::connection : Send: Subscribe(Subscribe { pid: PacketIdentifier(3), topics: [SubscribeTopic { topic_path: “hermes/audioServer/toggleOff”, qos: AtMostOnce }] })
[14:17:35.397946] DEBUG:rumqtt::connection : Send: Subscribe(Subscribe { pid: PacketIdentifier(4), topics: [SubscribeTopic { topic_path: “hermes/audioServer/default/replayRequest”, qos: AtMostOnce }] })
[14:17:35.397951] DEBUG:snips_audio_portaudio : Mike source capture started
[14:17:35.402722] DEBUG:snips_audio_portaudio : Portaudio: Ok(“PortAudio V19-devel (built Jan 23 2019 16:02:13)”)
[14:17:35.403067] DEBUG:snips_audio_portaudio : Looking for default input device
[14:17:35.403166] DEBUG:snips_audio_portaudio : Mike source capture ended
[14:17:35.406007] DEBUG:rumqtt::connection : snips-audio-server|10653-ubuntu-1 Received control message Suback(Suback { pid: PacketIdentifier(1), return_codes: [Success(AtMostOnce)] })
[14:17:35.412011] DEBUG:rumqtt::connection : snips-audio-server|10653-ubuntu-1 Received control message Suback(Suback { pid: PacketIdentifier(2), return_codes: [Success(AtMostOnce)] })
[14:17:35.455132] DEBUG:rumqtt::connection : snips-audio-server|10653-ubuntu-1 Received control message Suback(Suback { pid: PacketIdentifier(3), return_codes: [Success(AtMostOnce)] })
[14:17:35.455346] DEBUG:rumqtt::connection : snips-audio-server|10653-ubuntu-1 Received control message Suback(Suback { pid: PacketIdentifier(4), return_codes: [Success(AtMostOnce)] })
[14:17:35.497759] DEBUG:snips_audio_portaudio : Attempt 1
[14:17:35.497982] ERROR:snips_audio_server : NoDevice

root@ubuntu:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: seeed2micvoicec [seeed-2mic-voicecard], device 0: bcm2835-i2s-wm8960-hifi wm8960-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 7/7
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
card 1: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

root@ubuntu:~# arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: seeed2micvoicec [seeed-2mic-voicecard], device 0: bcm2835-i2s-wm8960-hifi wm8960-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

root@ubuntu:~# cat /etc/asound.conf
pcm.!default {
type asym
playback.pcm {
type plug
slave.pcm “hw:0,0”
}
capture.pcm {
type plug
slave.pcm “hw:0,0”
}
}

anything i’m missing? please help


#2

i don’t see anything wrong with alsa
this is very strange
could be snips aarch64 still has problem on audio?
anybody try snips on aarch64 platform?