Snips hotword detection while listening to music


#1

Hi,

I’m have a ReSpeaker on a Rpi3 which I also use for listening to music with Raspotify. While listening to music, snips doesn’t listen anymore, which is probably a feature, not a bug, but this prevents to ask snips to stop the music.
Any thoughts on how to do it anyway without installing a satellite?


#2

Hello,

It is not a bug and not a feature :slight_smile:
The problem comes from Alsa. When an app access to audio device, any other cannot access to audio device.
For that, you may have to change asound.conf for add dmix and dsnoop or use pulseaudio.

Ced


#3

@nxd4n you can use pulseaudio for AEC (Acoustic Echo Cancellation) there is an option in sam to configure this on a snips makerKit , you will also find a standalone instruction in this repo : https://github.com/treymarc/snips-app-radiofm


#4

Speaking of which, @marc, why can’t we set dmixed and dsnoop anymore?? If set as dmixed, snips-audio-server fails loading… This is… bad to say the least


#5

Is the dmixed and dsnoop still an issue? I was about to start setting that up when I came across this thread.
I was also considering trying the AEC option from sam, but I haven’t worked much with pulseaudio. It sounds like using pulseaudo removes the need for dsnoop, etc… but is there a downside to using it?