Snips-makers-tts customization and/vs mycroft

Hello everyone,

I have two questions taht I didn’t manage to find any answer to…

First one is regarding snips-makers-tts and the use of its options.
How do I find the list of pitch available , language and so on, available for offline TTS?
Another point is how / where do I find voice file to use with it? which format is accepted?

Second question is related to Mycroft.
As far as I understood, mycroft is somehow more accurate than default Snips voice handling. Is that statement right or do I missread?
If so, is there a way to integrate the offline features of Mycroft to my current Snips plateform ( Raspberry 3+ dedicated to Snips for the time being ) ?
Is there a tuto to do so?
I’ve seen the ultimate script (SnipsSuperTTS) of Psycho, but it encompass too many things for me, I just want to keep offline for everything. Maybe a specific configuration of this script might do the trick, but I will need some guidance on how doing it :slight_smile:

Many thanks in advance for your answers and help :slight_smile:

Hey,

I just had the same uestion and startet to experiment with the SnipsSuperTTS (https://gist.github.com/Psychokiller1888/cf10af3220b5cd6d9c92c709c6af92c2) and for now it also works offline. Unfortunately I wasn´t able to change the language. So if you want to use English it should work fine. You can also change the voice like state in the description.

You can go to https://mycroft.ai/documentation/mimic/ to first install microft
start with:

$ sudo apt-get install gcc make pkg-config automake libtool libicu-dev libpcre2-dev libasound2-dev

Then follow the building sequence. It should be pretty straight forward :wink:

Many thanks for the answer.

You raised a good point then, as I’m looking for a solution that works for French assistant :slight_smile:

Just to be absolutely clear on how to proceed:
First : the command at the end of your post
Second : follow up the building sequence
Third : using SnipsSuperTTS following “COMMON” and MycroftAI - Mimic parts. I assume that if I don’t install Google and Amazon SDK i should easily stick to offline features :slight_smile:

I see for Mimic the following :
Available voices: aew ahw aup awb axb bdl clb eey fem gka jmk ksp ljm rms rxr slt slt_hts
Or you can use an external voice on http.

Is a decription of the voice somewhere or is up to people to try them? (even if I think it’s second solution :wink: )
Could give me a hint on how does it work for “external voice on http” ?

Sorry for the noob questions… I’m quite a new comer on Snips and still struggling to find the right documentation, tutos and so on.

Hey,

yes exactly. Here is the rest of the needed comments.
You might need to install mpg123 first with sudo apt-get install libmpg123-dev

First, clone the git repository:

$ git clone https://github.com/MycroftAI/mimic.git

Navigate to the Mimic directory:

$ cd mimic

Generate the build scripts:

$ ./autogen.sh

Configure the build scripts:

$ ./configure --prefix="/usr/local"

Build from source:

$ make

Validate the build:

$ make check

Install the compiled code:

$ sudo make install

And then you need to change the snips.toml file

Yes I understood that the same way and it seems to work :wink:

I just tried it out. I only installed it this morning.

That´s why I haven´t tested this out so far.

I started with raspberry and snips 2 weeks ago. So I´m also quite new to this :wink:

Many thanks for the help :slight_smile:

Let you know my progress on that asap !

Edit: looking into mycroft, french is not really expected… I found that link but not sure if all the modifications are to be done : https://mycroft.ai/documentation/languages/
In my understanding the only modification I have to do on Mycroft side would be the step 1 of the guide:

Your primary language is set within your mycroft.conf file. Setting this at the user level ~/.mycroft/mycroft.conf file might look like:

{
  "max_allowed_core_version": 19.2,
  "lang": "it-it"
}

Please note that all configuration changes must result in a valid JSON file. If a change to your config does not seem to be working or you are unsure, please check the contents of your mycroft.conf file with one of the many JSON validators available online. A single misplaced comma can cause hours of frustration.

Am I correct on that? Other aspect are handled through SNIPS isn’t it?

Yeah I´m curious about it.

I´m not sure. For now how I understood it, Snips delivers everything you need. So their core task is the Speech To Text and Natural Language Understanding. Then you are able to switch things out as long it can communicate via MQTT.
So in the microft documentation (thanks for that link, wasn´t able to find something like this :smiley:) there are several options. The one you mention seems to be the overall language setting.
But I didn´t really get what step 6 means. Is it for translation of speech recognition?

EDIT:
There seems to be some promising things going on Better TTS for snips home But for now I won´t be able to implement it without a decent step by step guide

EDIT2:
Found this as well https://docs.snips.ai/additional-resources/faq/raspberry-pi-faq#how-can-i-change-the-tts-voices

So after some try nothing really good out of it…

For now I stick with basics and found no joy in trying to run Mycroft…
Not sure the French assistant on SNIPS is that friendly to mycroft :slight_smile:

I will try again as the trouble seems coming from the last update where the audio is almost totally failing.

So I ended up getting all that installed, up and running :slight_smile:

Well, it is not exactly the result expected yet, as I have some French words with a mighty US accent when it comes the time that SNIPS speaks :slight_smile:
Really fun and weird I must say !!!

I don’t have any clue on how and where I might somehow be able to configure the language…
There is no “mycroft.conf” anywhere and I’m no where near having a clue of what to look for…

Trancestar, or any good lad hanging on this forum, could you give me a hand on that?

Nice to hear that you achieved that!!!

Unfortunately I´m also clueless how to set the language. But I´m interested in any advise :wink:

1 Like

Maybe someone will end up on this topic and give a hand… :slight_smile:
Hope sweet hope :slight_smile: :slight_smile: :slight_smile:

I have sent a message @SakanaSan to see if some help can be offered :slight_smile:
Will see if somehow something comes up from that :wink: