Snips on RedHAt/CentOs/Fedora

Hi EveryOne !
I’m using snips for few weeks and it works great with raspberrypi and MQTT connections with my own home automation tool.
I managed to stop TV, start/stop lights:…

But all my desktops are installed with Fedora (.rpm based, not .deb).
Is there a way to install snips/sam with these platforms ?
I looked in the forum, unsuccessfull for now.

Thanks,
Sebastien.

Hi @seblef have you found a solution by now? I am using fedora too.

Thanks
Max

you will need to manually download the snips deb packages locally first, then you can convert the deb to rpm using alien (cf https://www.thegeekstuff.com/2010/11/alien-command-examples/)

I have not tried yet but I do not see any reason for it to not work.

let us know if you need the commandes to follow steps by steps

Hi
I am using the debian files from here: Install on debian 9 VM
then I transformed the deb files into rpm according to here: https://www.electricmonk.nl/log/2017/02/23/how-to-solve-rpms-created-by-alien-having-file-conflicts/
This is necessary because a simple alien would cause filesystem conflicts.
Instead of removing only / and /usr/bin, as said in electricmonks example, I removed all directories not directly linked to snips from the spec file. I cded into the directory and then build the rpm with
rpm --buildroot //snips-skill-server-0.60.1 -bb snips-skill-server-0.60.1-2.spec
cd into directory
rpm --buildroot //snips-template-0.60.1 -bb snips-template-0.60.1-2.spec
I then installed the packages with cd … && rpm -i snips*
I downloaded my assistant and unzipped to /usr/share/snips
starting skills server throws a missing skills error.
Do I miss some deb packages? Like audio-server et al?

for a minimal snips installation you need , in addition to your assistant from the console :

  • snips-audio-server
  • snips-hotword
  • snips-dialogue
  • snips-asr
  • snips-nlu

if those 5 process are running then you can test the platform , using snips-watch

if you want to run some action code from the assistant or with the skill server you need :

  • snips-template
  • snips-skill-server

if you do not have any skill, you will get a missing skills error

Hi Every One,

I tested with docker but did not manage to run it correctly.
I think it would be better/quicker to port my soft under debian. It’s only a question of library.

Hope those RPMs will exist one day.
Seblef.

1 Like

Conversion and Installation worked fine. Only snips-asr is missing libsnips_kaldi.so. I have only found https://s3.amazonaws.com/debian.snips.ai/stretch/pool/s/sn/snips-kaldi-atlas_0.24.2_amd64.deb . Is there a later version anywhere?

Needed to install and start mosquitto
After that my alsa lib threw some errors when starting the audio server. This is probably a misconfiguration on my side. I will check.