Snips on Synology DSM (Docker, server-only with satellites)

Hi all,

last few days I setup Snips satellite configuration with

  • Snips server on Synology DSM (918+ in my case)
  • satellites on Raspberry Pi Zero W

You may find the Docker container and some instructions for the Synology DSM here:

Best,
Martin

1 Like

Hi Martin,

I own a Synology 1812+ where I run a Jeedom docker container and I plan to read your contribution to create a new container for Snips server.
What are your feebacks after a while, are you satisfied with your integration in Synology ?
Performances are enough ?
Is it stable ?
Does Snips upgrade itself to new versions automatically ?

Thanks for your help :slight_smile:

Manu

Hi @mfdir,

I have exactly the same use case and tried your docker image. There were some problems I could solve. But now I am facing a problem which is harder.

I got the following error message:
Could not start MQTT client on localhost:1883
-> caused by: Connection refused (os error 111)
/start-snips.sh: line 88: wait: `’: not a pid or valid job spec

Do you have an idea?
Any hint appreciated!

Thanks in advance!

Bye
freddy

Hi Freddy,

In my opinion it depends on your network configuration and this one is issued when you run the Container not when compiling the image. Maybe you need to use type of network=host ?

Cheers
Andreas

Hi Martin,

I am also trying to compile a docker container to run it on RasPI 4. I am struggling when i need to issue the sam connect {host} command because it is interactive and expects user input: user id and password.
Did you find a way to get this solved and build this step automatically?
Or do you know another way, e.g. copy the files Sam updates when snips is configured properly, so i can copy them into the container, when everything is done?

Cheers
Andreas