Snips won't respond


#1

Today I tried the fist time to get snips to work. Ultimately I intend to use it mainly in combination with Home Assistant to turn off the lights when I’m too lazy to get up from my couch.

Right now however, I’d be glad if I could just get it to tell me what the weather is going to be like tomorrow.

I seem to fail miserably at this task.

I installed Snips step by step exactly like in this documentation: https://docs.snips.ai/guides/raspberrypi/manual-setup , and created and installed an assistant via the console. (I also tried the example assistant - no luck)

However it just won’t respond.

It clearly understands what I’m saying and knows what I want it to reply, but it doesn’t.

using snips-watch -vvv I get this:

[20:20:32] [Hotword] was asked to toggle itself 'on'[20:24:35] [Hotword] detected on site default, for model hey_snips
[20:24:35] [Asr] was asked to stop listening on site default
[20:24:35] [Hotword] was asked to toggle itself 'off' on site default
[20:24:35] [Dialogue] session with id '38ec5e9b-1fdc-xxxx-xxxx-5d0c77b7dfd4' was started on site default
[20:24:35] [AudioServer] was asked to play a wav of 41.1 kB with id '2ea11e8c-xxxx-xxxx-917d-9ae1fba073c0' on site default
[20:24:36] [AudioServer] finished playing wav with id '2ea11e8c-92a3-xxxx-xxxx-9ae1fba073c0'
[20:24:36] [Asr] was asked to listen on site default
[20:24:39] [Asr] captured text "wie wird das wetter morgen" in 3.0s
[20:24:39] [Asr] was asked to stop listening on site default
[20:24:39] [AudioServer] was asked to play a wav of 93.1 kB with id '6923a36b-xxxx-xxxx-a395-7ebb20c0fd0e' on site default
[20:24:40] [AudioServer] finished playing wav with id '6923a36b-xxxx-xxxx-a395-7ebb20c0fd0e'
[20:24:40] [Nlu] was asked to parse input "wie wird das wetter morgen"
[20:24:40] [Nlu] detected intent domi:searchWeatherForecast with probability 0.923 for input "wie wird das wetter morgen"
              Slots ->
                 forecast_start_date_time -> 2019-01-17 00:00:00 +01:00 (confidence: 1.000)
[20:24:40] [Dialogue] New intent detected domi:searchWeatherForecast with probability 0.923
              Slots ->
                 forecast_start_date_time -> 2019-01-17 00:00:00 +01:00 (confidence: 1.000)
[20:24:45] [Dialogue] session with id '38ec5e9b-xxx-xxxx-xxxx-5d0c77b7dfd4' was ended on site default. The session was ended because one of the component didn't respond in a timely manner
[20:24:45] [Asr] was asked to stop listening on site default
[20:24:45] [Hotword] was asked to toggle itself 'on' on site default

So, what is going on there - or better; what is not working correctly?

Thanks in advance!

EDIT: Also, sound does work - I can hear that confirmation sound after “hey Snips” and after I finished talking


#2

So what system do you have to actually respond to the intent?


#3

The simple answer is: I don’t know.

Do you mean like what tts provider?!

Like I said I’m completely new to this and just followed the instructions in that documentation.
At the point where it says “At this point, you have a fully working setup, and you can start asking questions to your device, such as:” (under installing a demo assistant), it did not respond but only shows this log.

I believe this is where the problem must be:

[20:24:45] [Dialogue] session with id '38ec5e9b-xxx-xxxx-xxxx-5d0c77b7dfd4' was ended on site default. The session was ended because one of the component didn't respond in a timely manner

I just can’t figure out what I have done wrong


#4

There’s simply nothing to respond to you. Try to use an app that does respond something


#5

Could you please explain that further?!

What app? Where do I get it from? Is there a documentation on how to do that?!
I couldn’t find anything else than the link that I posted earlier and thought that’s the way to get snips to work :frowning:


#6

You may have a look here:

https://medium.com/snips-ai

there you will find some projects you could build with snips for a start


#7

I find all this really confusing tbh

I thought snips was supposed to be:

  1. Install snips on pi
  2. create assistant
  3. enjoy

:thinking:

I guess I’ll just have to wait until it is actually released - this is a bit too high for me :joy:


#8

If you created an assistant in the Snips Console, like you said in your original post, you just have to click on “Add an App”, and then you can choose whatever app you want. Without any apps, your assistant won’t respond because it just doesn’t have any actions configured. Can you try adding some apps from the Snips Store to your assistant and then install your assistant again on your Raspberry Pi?


#9

For what it’s worth, I was having the exact same issue as described above, and was able to fix it. I’m running the basic Raspbian GUI on my Pi, and I have it hooked up to a TV through HDMI. I followed the quickstart tutorial, which includes installing the demo assistant. At first, I set up my Snips audio to output through the TV just to test, and that worked fine.

When I set it up through a Jabra 410 USB mic/speaker, all the audio was sped up. As hilarious as a chipmunk assistant would be, I was able to find the advice here, about how to configure audio to play to the Jabra correctly. In between making configuration changes, I always did a reboot.

However, when using those settings, I got the exact issue described above: I could hear the wake sound but got no response from Snips. Using sam watch I also saw a similar line:

[20:24:45] [Dialogue] session with id '38ec5e9b-xxx-xxxx-xxxx-5d0c77b7dfd4' was ended on site default. The session was ended because one of the component didn't respond in a timely manner

Because of the speaker differences I thought it was something to do with my audio setup. However, what ended up fixing the demo assistant was following the manual installation instructions on the snips-skill-weather-tts GitHub page readme. Maybe it was something to do with restarting the snips-skill-server, although I thought a reboot would in theory take care of that too.

TL;DR, assuming you have the demo assistant installed, try:

sudo systemctl stop snips-skill-server
cd /var/lib/snips/skills/snips-skill-weather-tts/
sh setup.sh
sudo systemctl start snips-skill-server

#10

oh those are meant by “apps” … yeah - obviously I created my assistant adding a few of those “apps”


#11

thanks I’ll try that!


#12

You just need to configure it to connect to Home Assistant and configure your intents there.

Add this to mosquitto.conf on your snips server replacing username/password and address.

connection snipsmqtt
address HASS_MQTT_ADDRESS:1883
#remote_username HASS_MQTT_USER
#remote_password HASS_MQTT_PASSWORD
remote_clientid snips
start_type automatic
topic hermes/dialogueManager/# in
topic hermes/asr/# in
topic hermes/hotword/# out

topic hermes/intent/# out
topic hermes/asr/# out
topic hermes/hotword/# out
topic hermes/nlu/# out

Then if you install the home assistant app in your assistant you should be all set.


#13

I tried to do that but found out, that there is no snips-skill-server running/installed

pi@snips-base:~ $ sudo systemctl stop snips-skill-server
Failed to stop snips-skill-server.service: Unit snips-skill-server.service not loaded.

Also there is nothing iside the /var/lib/snips folder :thinking: