[Solved] Calculator test assistant installed, but no response to wakeword (Raspberry Pi 3 with Matrix Voice)

I apologize if this is not the correct category. I couldn’t find something that was obviously more suitable.

I have been following the Quick Start guides for the Raspberry Pi and for making an assistant with the Console. I’m trying to set up snips on a Raspberry Pi 3 with a Matrix Voice. I have been able to make it all the way to the section of the guide where the assistant has been installed and where we try to test the recognition. Prior to this I had tested the microphone using sam test microphone and was able to hear what I said played back through the speakers. However, when saying the wake word, “Hey snips”, I hear no response sounds and sam watch remains empty.

How can I solve this problem? Please let me know if there is any more information I can provide. As an aside, it seems that the Matrix Voice is not used very often here. Does it not work very well?

It is working fine for me
image

Can you tell me on which project you are working on

Hello again, thank you for the reply. I was following the Quick Start guide, and used the following command:

sam install assistant

After that I tried to use the wake word. It didn’t say anything about manually running anything on the RPi3. Do I have to do that?

Yes, I made an assistant using the Quick Start guide here - https://docs.snips.ai/getting-started/quick-start-console. I was trying to test that before making my own assistant.

No, you don’t have to run anything unless you made your own assistant
Have you configure snips.toml file for mics on RPi ?
sudo nano /etc/snips.toml

After installing are you able to see snips assistant is running.

You can also install demo to check
sam install demo

Now, test the assistant by saying
“Hey Snips!”
“What will the weather be like in Madagascar in two days?”

The response from Snips should be:
“You asked for the weather in Madagascar in two days.”

As you are making your own app .
You have to deploy it on RPi and then write a code for it

Can you tell me all the procedure you are following to setup RPi, Matrix Voice and Snips

I’m just using the Quick Start guides. I followed this one https://docs.snips.ai/getting-started/quick-start-raspberry-pi until Step 5, where you create an assistant using https://docs.snips.ai/getting-started/quick-start-console. After creating that assistant following the guide, I installed it using sam install assistant. Then in Step 6, it asks me to test the wake word recognition and speech recognition. That is where I’m having the problem. Maybe I missed a step or did something incorrectly?

What I understand is you are installing assistant using sam install assistant but you have to use is when you deploy your app you will be prompt by sam install project… you have to use that
I also write instruction on Hackster.io if you want to see you can
https://www.hackster.io/ruchir1674/controlling-lights-using-raspberry-pi-matrix-voice-and-snips-c97a7c

Ruchir, thank you so much again! So I looked at your article and even though I was able to get my microphone and speaker working using sam setup audio, I looked at the /etc/snips.toml and noticed that in the microphone section it was still set to the default! So I changed it to the Matrix Voice one with mike = “MATRIXIO SOUND: - (hw:2,0)”

Now it works correctly. I have no idea why the sam setup audio command doesn’t actually modify the snips.toml file.

Welcome!!! Happy that you are able to figured it out. Sam setup audio is just use to select the microphone and speaker

Hi @ruchir, I got the same problem. I tested the demo weather skill and I can hear a chime whenever I say “Hey Snips” but does not get any TTS response. See screenshot below.

I am using RPI3 and Matrix Voice. I use matrix as the input and HDMI as the output.

Please advice. Thanks