[SOLVED] EAI AGAIN Error when trying updating assistant


#1

Hey guys, im running into this error message when i´m trying to update my assistant:

 Unable to install the assistant: NLU training error: request to https://external-gateway.snips.ai/v3/assistant/proj_XXXXXXXXX/status failed, reason: getaddr info EAI_AGAIN external-gateway.snips.ai external-gateway.snips.ai:443

when i ping the adress external-gateway.snips.ai from my computer i get a respond, when i ping the adress from the snips raspberry pi i get:

ping: external-gateway.snips.ai: Temporary failure in name resolution

How can i resolve this issue? Thanks for the help


#2

My pings to the servers respond


#3

Tried my other raspberry pi and this device could ping the adresse without an error.
After reading other forums with this error linked to DNS i looked up the dns config file on the ping-working rapsberry pi and copied the content and pasted it in the dns config file from the snips raspberry file. And it worked.

access the dns config file:
###Open The dns config file with an editor in the command line

sudo nano /etc/resolv.conf