[SOLVED] Google ASR does not work properly after update to 0.61.1


today i have updated whole platform and assistant to 0.61.1. After that Google ASR does not properly recognises voice. In most cases it does not recognises voice at all (i get timeout):

INFO:snips_dialogue_lib::coordinator::coordinator: Session [f35f4dfb-911f-4db7-a754-2d7bc435d416]: closing session which was active: Timeout

Sometimes sentences are recognized partially, and very, very rarely - properly, but then i get:

WARN:snips_dialogue_lib::coordinator::coordinator: No Session found for this response: AsrCapture(AsrPayload { text: "chcę słuchać muzyki", tokens: None, likelihood: 0.78073645, seconds: 15.0 })

I see no errors in logs, all needed services are running. Everything worked fine before update.
My setup:

  • Raspberry Pi 3B+ (master without mic and speaker)
  • Raspberry Pi 3B (satellite with mic and speaker)

I just wanted you to know, that I have just downgraded snips-asr-google to 0.60.12 and… everything is working again! Now I’m sure that there is something wrong with new version of that package.

1 Like

Hello Chris,

I have re rested snips-asr-google, no issues on my side, everything seems to work.

So that’s strange. I have tested it in my environment by upgrading and downgrading snips-asr-google and result is clear: version 0.60.12 works, 0.61.1 don’t. The symptom is that I can’t hear “end of input” sound and the sentence is recognised partially or not recognised at all. As I wrote before: I can’t see any errors in logs. How can i provide more info about this issue? Or maybe I will wait for next release and check how it will behave?

Ok, I have a better understanding.

Let me try a different test.

I have upgraded asr to 0.61.1 and here is the output i get from snips-asr-google -v:

[17:18:43.299045] INFO :snips_asr_google_lib::google_auth: Connecting using service account file “/usr/share/snips/googlecredentials.json”
[17:18:43.299502] DEBUG:snips_asr_google_lib::stream_ext : [“backpressure-thread”] Thread spawned
[17:18:43.299442] DEBUG:snips_asr_google_lib::google_auth: credentials: Credentials {
t: “service_account”,
project_id: “assistant-",
private_key_id: "
private_key: “",
client_email: "
client_id: "
auth_uri: “https://accounts.google.com/o/oauth2/auth”,
token_uri: “https://oauth2.googleapis.com/token”,
auth_provider_x509_cert_url: “https://www.googleapis.com/oauth2/v1/certs”,
client_x509_cert_url: "https://www.googleapis.com/robot/v1/metadata/x509/assistant%40assistant-
[17:18:43.300197] DEBUG:snips_asr_google_lib::google_auth: claims: JwtClaims {
iss: "assistant@assistant-
scope: “https://www.googleapis.com/auth/cloud-platform”,
aud: “https://www.googleapis.com/oauth2/v4/token”,
exp: 1551806323,
iat: 1551802723
[17:18:58.509443] DEBUG:snips_asr_google_lib::stream_ext : [“backpressure-thread”] Thread stop

In comparison with 0.60.12 it looks like Snips can’t hear me. But why? I tried even speak louder and get close to the mic, but result is the same.


I have stumbled on your problem.

And then… it disappeared :confused:

For some reason it does not happen all the times

I guess we need to dig that a bit further

Another remark that i have noticed a moment ago: when I make bigger pause after “begin of input sound” and then I start to speak, asr starts recognition, but the final result arrives with 12 seconds delay:

[17:26:46.213242] DEBUG:snips_asr_google_lib::google_asr : Recognized results {alternatives {transcript: “w”} stability: 0.01}
[17:26:46.414507] DEBUG:snips_asr_google_lib::google_asr : Recognized results {alternatives {transcript: “w\305\202\304\205cz”} stability: 0.01}
[17:26:46.996172] DEBUG:snips_asr_google_lib::google_asr : Recognized results {alternatives {transcript: “W\305\202\304\205cz You could”} stability: 0.01}
[17:26:46.999660] DEBUG:snips_asr_google_lib::google_asr : Recognized results {alternatives {transcript: “W\305\202\304\205cz”} stability: 0.9} results {alternatives {transcript: " You could"} stability: 0.01}
[17:26:47.008609] DEBUG:snips_asr_google_lib::google_asr : Recognized results {alternatives {transcript: “W\305\202\304\205cz”} stability: 0.9} results {alternatives {transcript: " komputer"} stability: 0.01}
[17:26:47.591006] DEBUG:snips_asr_google_lib::google_asr : Recognized results {alternatives {transcript: “W\305\202\304\205cz komputer”} stability: 0.9}
[17:26:59.628363] DEBUG:snips_asr_google_lib::stream_ext : [“backpressure-thread”] Thread stop
[17:26:59.780809] DEBUG:snips_asr_google_lib::google_asr : Recognized results {alternatives {transcript: “W\305\202\304\205cz komputer” confidence: 0.9631079} is_final: true}
[17:26:59.780946] DEBUG:snips_asr_google_hermes : Text captured: TextCapturedMessage { text: “Włącz komputer”, likelihood: 0.9631079, tokens: None, seconds: 15.0, site_id: “room”, session_id: Some(“b1e67730-aa1d-4c9e-8ad3-6790e1c48539”) }, is_final: true

So that’s why i get timeout in snips_dialogue_lib::coordinator::coordinator.

On my side:

Here is my config:

  • 2 maker kits with 1.1.0 (0.61.2) and the current one under validation
  • snips-led-skills
  • snips-asr-google up and running
  • a basic assistant with the weather application and Ozie’s Calculator
  • Sound feedback is enabled

I’m running them side by side


  • The sound feedback seems ok (opening and closing the dialogue session)
  • From time to time my utterances are not catched at all and the device stays in listening mode until the time out (30% to 50% I would say)

Does it depicts your situation?

Yes, it looks simmilar. The only difference is that i get no “end of input sound” when i start speaking right after “begin of input sound”. Simply - Snips won’t hear me then and i get timeout without any sound notification. If i make a 3-4 sec. pause after “begin of input” then it looks like i have described in my prev. post.

Hi @chrisb,

I have updated the issue you opened: https://github.com/snipsco/snips-issues/issues/90

We are still investigating this.

I think I found a reliable workaround.

Downgrade only snips-asr-google to version 0.60.12
sudo apt install snips-asr-google=0.60.12

I have tested 30 utterances side by side with the version 0.61.1.

Can you tell me if it works on your side?

Yes, it is working on version 0.60.12. I wrote about in here -> Google ASR does not work properly after update to 0.61.1 (second post).

:confounded: You are right! I misread this.

Thanks you so much for your insights.

I guess we need to stick with this workaround at the moment.

I’ll update the Known Issues of the release.

I’m glad I could help :slight_smile:

Can’t downgrade anymore… Latest update did not fix google asr… Can’t use anything anymore…

1 Like

I am little confused that this topic is closed. I just tried the current snips-asr-google and I don’t get it work. I have launched it with -v flag but apart from printing the config it does - nothing. Credentials are provided but apparently it does not even connect. When I utter a sentence and it is passed to ASR it tries to connect to MQTT and that’s it. Normal snips-asr works as expected.

Yes, this wasn’t solved yet, it’s not a priority for Snips to have Google ASR requests working :slight_smile:

Hi @cburghardt,

On my side I have retested it, now it seems to work using the latest version of snips-asr-google

We are a bit puzzled by this one :confused:

Recently I have build docker image with Snips (https://github.com/ChrisB85/snips_docker)
because I moved from Raspberry Pi to Ubuntu server and forgot to hold packages on 0.61.1. The result was the same - Google ASR wasn’t working properly.